POJ1797 Heavy Transportation【並查集+貪心】

Enjoy_process發表於2018-10-17

Heavy Transportation

Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 50413   Accepted: 13007

Description

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

Source

TUD Programming Contest 2004, Darmstadt, Germany

問題連結:POJ1797 Heavy Transportation

問題描述:給定n個交叉點(從1開始編號)有m個雙向的街道連結它們,每條街道都有一個最大負重,問從1號結點到n號結點的路線方案中,最小負重街道的最大值為多少。

解題思路:並查集+貪心,按照邊的最大負重從大到小加邊,直到使得1號結點和n號結點連通

AC的C++程式:

#include<iostream>
#include<algorithm>
#include<cmath>

using namespace std;

const int N=1005;

int pre[N];

//初始化函式 :使各個結點是自己的父節點 
void init(int n)
{
	for(int i=1;i<=n;i++)
	  pre[i]=i;
} 

int find(int x)
{
	int r=x;
	while(r!=pre[r])
	  r=pre[r];
	//路徑壓縮
	while(x!=r){
		int i=pre[x];
		pre[x]=r;
		x=i;
	}
	return r; 
}

struct Edge{
	int u,v,c;
	bool operator<(const Edge &a)const
	{
		return c>a.c;
	}
}e[N*N/2];

void join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	  pre[fx]=fy;
} 

int main()
{
	int T,n,m;
	scanf("%d",&T);
	for(int t=1;t<=T;t++){
		scanf("%d%d",&n,&m);
		for(int i=0;i<m;i++)
		  scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].c);
		sort(e,e+m);
		init(n);
		//從大到小加邊 
		for(int i=0;i<m;i++){
			join(e[i].u,e[i].v);//新增邊d[i]
			if(find(1)==find(n)){//新增邊d[i]後1號結點和2號結點連通了,這就是答案
			  printf("Scenario #%d:\n%d\n\n",t,e[i].c); 
			  break;
			}
		} 
	}
	return 0;
}

 

相關文章