POJ 2492 A bug's life【擴充套件域 | 邊帶權並查集】

神探小小迪發表於2018-09-25

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

題解:擴充套件域解法:用 n+x 表示與 x 性別相反的蟲子。 

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 2000+7;
int fa[maxn<<1];
int get(int x) {
    if(x == fa[x]) return x;
    return fa[x] = get(fa[x]);
}
void Merge(int x, int y) {
    fa[get(x)] = get(y);
}
int main()
{
    int t, n, m;
    int cnt = 0;
    scanf("%d", &t);
    for(int i = 1; i <= t; i++) {
        int flag = 1;
        scanf("%d %d", &n, &m);
        for(int i = 1; i <= 2*n; i++)
            fa[i] = i;
        int a, b;
        while(m--) {
            scanf("%d %d", &a, &b);
            if(get(a) != get(b)){//a, b 不是同性
                Merge(a+n, b);//合併同一性別的蟲子
                Merge(a, b+n);
            }
            else flag = 0;//a, b是同性
        }
        printf("Scenario #%d:\n", i);
        if(!flag) printf("Suspicious bugs found!\n");
        else printf("No suspicious bugs found!\n");
        if(i != t) printf("\n");
    }
    return 0;
}

 

相關文章