YT05-動態歸劃求解課後題目-1004—Max Sum -(6.21日-煙臺大學ACM預備隊解題報告)
Max Sum
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 10 Accepted Submission(s) : 9
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position
of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
Author
Ignatius.L
一開始容易想到的都是暴力方法,一個個向後面走,只要和大於max的就記錄,但是會超時
for (i=1;i<= m;i++)
{
int sum=0;
for (int j= i;j<m;j++)
{
sum+=data [j];
if (sum>max)
{
max=sum;
point1=i;
point2=j;
}
}
}
可以用動態規劃,對演算法進行改進,起始還是從頭開始,一直往後搜尋,當遇到和小於0的時候,就對sum重新賦值,並把記錄起始的點變為和為0的後一位,和不小於0的,就繼續搜尋下去.
#include <iostream>
using namespace std;
int main()
{
int T,n,i,max,num,sum;
int jilu1,jilu2,qian,hou;
//定義jilu1、jilu2為運算中記錄起始整數位置,qian、hou為最後結果
cin>>T;
for(int k=1;k<=T;k++)
{
cin>>n;
sum=max=-1000;
qian=hou=1;
jilu1=jilu2=1;
for(i=1;i<=n;i++)
{
cin>>num;
if(sum>=0) {jilu2++;sum+=num;}
else if(sum<0)
{sum=num;jilu1=i;jilu2=i;}
//當前面集合為負數時,不用將前面數字加入計算和,直接令sum = 新輸入元素
if(max<sum)
{
max=sum;
qian=jilu1;
hou=jilu2;
}
}
cout<<max<<‘ '<<qian<<‘ '<<hou<<endl;
if(k!=T)
cout<<endl;
}
return 0;
}
相關文章
- [ABC376E] Max × Sum 題解
- 動態規劃求解最長上升子序列問題動態規劃
- leetcode題解(動態規劃)LeetCode動態規劃
- 動態規劃解題方法動態規劃
- LeetCode:動態規劃+貪心題目整理LeetCode動態規劃
- 動態規劃分類題目總結動態規劃
- 動態規劃 擺花 題解動態規劃
- 湖南大學2020屆ACM新生賽 部分題解ACM
- AcWing 1049. 大盜阿福 【 動態規劃(狀態機) 】 題解動態規劃
- 演算法刷題:LeetCode中常見的動態規劃題目演算法LeetCode動態規劃
- 大學畢業課題研究開題報告PPT分享-20套可下載
- 青年大學習第十季第五期題目和答案(含課後習題)
- 【ACM程式設計】動態規劃 第二篇 LCS&LIS問題ACM程式設計動態規劃
- c++求解獎券題目C++
- 動態規劃專題動態規劃
- 好題——動態規劃動態規劃
- 動態規劃題單動態規劃
- 【LeetCode】416. Partition Equal Subset Sum 解題報告(Python & C++)LeetCodePythonC++
- 強化學習(三)用動態規劃(DP)求解強化學習動態規劃
- [LeetCode解題] -- 動態規劃二 [ 子串、子序列問題 ]LeetCode動態規劃
- 洛谷題單指南-動態規劃2-P1004 [NOIP2000 提高組] 方格取數動態規劃
- 03/10/2024 上課筆記 & 解題報告筆記
- 測試面試題目求解答面試題
- Leetcode 題解演算法之動態規劃LeetCode演算法動態規劃
- 【ACM演算法競賽日常訓練】DAY4題解與分析【樹】【子序列】| 組合數學 | 動態規劃ACM演算法動態規劃
- 動態規劃練習題動態規劃
- 動態規劃做題思路動態規劃
- 08.計劃任務課後習題
- 動態規劃_備忘錄法_矩陣鏈乘問題動態規劃矩陣
- matlab求解線性規劃問題Matlab
- 從“股票問題”談動態規劃問題的解決思路動態規劃
- 大廠常考動態規劃演算法題動態規劃演算法
- 2020-10-30 ACM實踐報告部分程式題ACM
- 動態規劃解0-1揹包問題動態規劃
- 【動態規劃】揹包問題動態規劃
- 我的動態規劃題單動態規劃
- 做題記錄 --- 動態規劃動態規劃
- 揹包問題----動態規劃動態規劃
- 動態規劃之子序列問題動態規劃