(非原創)PAT甲級1123 Is It a Complete AVL Tree (30分)|C++實現
一、題目描述
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 20). Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, insert the keys one by one into an initially empty AVL tree. Then first print in a line the level-order traversal sequence of the resulting AVL tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line. Then in the next line, print YES if the tree is complete, or NO if not.
Sample Input 1:
5
88 70 61 63 65
Sample Output 1:
70 63 88 61 65
YES
Sample Input 2:
8
88 70 61 96 120 90 65 68
Sample Output 2:
88 65 96 61 70 90 120 68
NO
二、解題思路
這道題目考到了AVL樹的基本操作和層序遍歷,對於AVL樹,如果出現了某個結點孩子為空,並且後面的結點還有孩子結點,則它不是一個完全二叉樹。但是AVL樹的操作還是有點複雜了,由於做的練習比較少,對AVL樹的理解也沒有很深,所以這裡也不是用的自己的程式碼,詳情可參考柳神的程式碼。
1123 Is It a Complete AVL Tree (30分)
三、AC程式碼
#include <iostream>
#include <vector>
#include <queue>
using namespace std;
struct node {
int val;
struct node *left, *right;
};
node* leftRotate(node *tree) {
node *temp = tree->right;
tree->right = temp->left;
temp->left = tree;
return temp;
}
node* rightRotate(node *tree) {
node *temp = tree->left;
tree->left = temp->right;
temp->right = tree;
return temp;
}
node* leftRightRotate(node *tree) {
tree->left = leftRotate(tree->left);
return rightRotate(tree);
}
node* rightLeftRotate(node *tree) {
tree->right = rightRotate(tree->right);
return leftRotate(tree);
}
int getHeight(node *tree) {
if (tree == NULL) return 0;
int l = getHeight(tree->left);
int r = getHeight(tree->right);
return max(l, r) + 1;
}
node* insert(node *tree, int val) {
if (tree == NULL) {
tree = new node();
tree->val = val;
}else if (tree->val > val) {
tree->left = insert(tree->left, val);
int l = getHeight(tree->left), r = getHeight(tree->right);
if (l - r >= 2) {
if (val < tree->left->val)
tree = rightRotate(tree);
else
tree = leftRightRotate(tree);
}
} else {
tree->right = insert(tree->right, val);
int l = getHeight(tree->left), r = getHeight(tree->right);
if (r - l >= 2) {
if (val > tree->right->val)
tree = leftRotate(tree);
else
tree = rightLeftRotate(tree);
}
}
return tree;
}
int isComplete = 1, after = 0;
vector<int> levelOrder(node *tree) { //層序遍歷
vector<int> v;
queue<node *> queue;
queue.push(tree);
while (!queue.empty()) {
node *temp = queue.front();
queue.pop();
v.push_back(temp->val);
if (temp->left != NULL) {
if (after) isComplete = 0;
queue.push(temp->left);
} else {
after = 1;
}
if (temp->right != NULL) {
if (after) isComplete = 0;
queue.push(temp->right);
} else {
after = 1;
}
}
return v;
}
int main() {
int n, temp;
scanf("%d", &n);
node *tree = NULL;
for (int i = 0; i < n; i++) {
scanf("%d", &temp);
tree = insert(tree, temp);
}
vector<int> v = levelOrder(tree);
for (int i = 0; i < v.size(); i++) {
if (i != 0) printf(" ");
printf("%d", v[i]);
}
printf("\n%s", isComplete ? "YES" : "NO");
return 0;
}
相關文章
- PAT甲級1110 Complete Binary Tree (25分)|C++實現C++
- PAT甲級1126~1130|C++實現C++
- PAT甲級1122 Hamiltonian Cycle (25分)|C++實現C++
- PAT甲級1154 Vertex Coloring (25分)|C++實現C++
- 【PAT甲級A1084】Broken Keyboard (20分)(c++)C++
- PAT甲級1032 Sharing
- 【PAT甲級A1038】Recover the Smallest Number (30分)(c++)C++
- PAT甲級1030 Travel Plan
- 浙大PAT甲級考試
- PAT甲級1023 Have Fun with Number
- 菜鳥記錄:c語言實現PAT甲級1010--RadixC語言
- Root of AVL Tree
- 【PAT甲級A1065】A+B and C (64bit) (20分)(c++)C++
- PAT甲級-1015. Reversible Primes (20)
- PAT 甲級 1152 Google Recruitment (20分)GoUI
- 20年春季甲級pat考試
- PAT甲級-1014. Waiting in Line (30)(模擬)AI
- PAT甲級真題1069 數字黑洞(巧妙解法)
- PAT甲級考試題庫題目分類
- 2024 秋季PAT認證甲級(題解A1-A4)
- PAT甲級-1140. Look-and-say Sequence (20)(模擬)
- 1123:影像相似度(C C++)C++
- PAT乙級——1093(字串匹配)Java實現字串匹配Java
- 2021.9.12週六PAT甲級考試覆盤與總結
- 19年春季第二題 PAT甲級 1157 Anniversary(25 分)
- 2020年7月第2題 PAT甲級真題 The Judger (25分)
- 手撕AVL樹(C++)C++
- 夕甲甲——孔乙己之C++版C++
- PAT:1020. Tree Traversals (25) AC
- PAT(甲級)2020年秋季考試 7-1 Panda and PP Milk (20分)
- c++版的NMS(非極大抑制)實現C++
- PAT-A Java實現Java
- 222. Count Complete Tree Nodes(Leetcode每日一題-2020.11.24)LeetCode每日一題
- C/C++ Qt Tree與Tab元件實現分頁選單C++QT元件
- PAT乙級——1092(陣列排序 自定義sort)Java實現陣列排序Java
- Git常用命令(非原創)Git
- PAT 乙級
- 【PAT乙級、C++】1024 科學計數法 (20分)C++