PAT甲級1032 Sharing

冷眼觀world發表於2020-11-16

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.
在這裡插入圖片描述
Figure 1
You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105​​ ), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:
Address Data Next
whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

思路

思路就是將兩個單詞存入兩個矩陣,找公共尾綴。但是這題有點迷,題目上suffix應該是尾綴的意思,應該要兩個單詞尾部有公共鏈才算,但是我從尾向前遍歷找公共鏈會出錯,從頭到尾找第一個公共點反而對了…

#include <iostream>
#include <vector>
#include <map>
#include <cstdlib>
using namespace std;
struct node
{
	int address;
	char data;
	int next;
};
int main()
{
	int word1, word2, n;
	cin >> word1 >> word2 >> n;
	map<int, node> mp;
	for (int i = 0; i < n; i++)
	{
		node s;
		cin >> s.address >> s.data >> s.next;
		mp[s.address] = s;
	}
	vector<node> w1, w2;
	while (word1 != -1)
	{
		w1.push_back(mp[word1]);
		word1 = mp[word1].next;
	}
	while (word2 != -1)
	{
		w2.push_back(mp[word2]);
		word2 = mp[word2].next;
	}
	map<int, bool> check;
	for (int i = 0; i < w1.size(); i++)
		check[w1[i].address] = true;
	int temp = -1;
	for (int i = 0; i < w2.size(); i++)
	{
		if (check[w2[i].address] == true)
		{
			temp = w2[i].address;
			break;
		}
	}
	if (temp == -1)
		cout << -1;
	else
		printf("%05d", temp);
	system("pause");
	return 0;
}

相關文章