PAT甲級-1140. Look-and-say Sequence (20)(模擬)
1140. Look-and-say Sequence (20)
Look-and-say sequence is a sequence of integers as the following:
D, D1, D111, D113, D11231, D112213111, ...
where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.
Input Specification:
Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (<=40), separated by a space.
Output Specification:
Print in a line the Nth number in a look-and-say sequence of D.
Sample Input:1 8Sample Output:
1123123111
題目意思:
對於樣例 :D, D1, D111, D113, D11231, D112213111,
D是首項“D”,其中D是一個給定的0~9的整數;
D1表明D中連續“D”有“1”個;
D111表明D1中連續“D”有“1”個,連續“1”有“1”個;
D113表明D111中連續“D”有“1”個,連續“1”有“3”個;
D11231表明D113中連續“D”有“1”個,連續“1”有“2”個,連續“3”有“1”個;
以此類推……
給定D,求第N項的表示方法。
解題思路:
用字元陣列儲存,依次遍歷前一個字元,計數連續出現的字元,存入當前字元。
#include<bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
#define MAXN 1010
string a[MAXN];
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("F:/cb/read.txt","r",stdin);
//freopen("F:/cb/out.txt","w",stdout);
#endif
ios::sync_with_stdio(false);
cin.tie(0);
int d,n;
cin>>d>>n;
a[0]=char(d+'0');
a[1]=a[0]+"1";
for(int i=2; i<n; ++i)
{
string s=a[i-1];
int cnt=1;
int len=s.length();
for(int j=1; j<len; ++j)//遍歷前一個串
{
if(s[j]==s[j-1]) ++cnt;
else
{
a[i]+=s[j-1];//元素
a[i]+=char(cnt+'0');//個數
cnt=1;
}
}
a[i]+=s[len-1];//加上最後一次的計數
a[i]+=char(cnt+'0');
}
//for(int i=1; i<n; ++i)
cout<<a[n-1]<<endl;
return 0;
}
相關文章
- PAT甲級-1014. Waiting in Line (30)(模擬)AI
- PAT 甲級 1152 Google Recruitment (20分)GoUI
- 20年春季甲級pat考試
- PAT甲級-1015. Reversible Primes (20)
- 【PAT甲級A1084】Broken Keyboard (20分)(c++)C++
- PAT甲級1032 Sharing
- PAT甲級1030 Travel Plan
- 浙大PAT甲級考試
- PAT甲級1023 Have Fun with Number
- 【PAT甲級A1065】A+B and C (64bit) (20分)(c++)C++
- PAT(甲級)2020年秋季考試 7-1 Panda and PP Milk (20分)
- PAT甲級1126~1130|C++實現C++
- 【PAT A1051】【棧/模擬】
- PAT-B 1085 PAT單位排行【模擬】
- PAT甲級真題1069 數字黑洞(巧妙解法)
- PAT甲級考試題庫題目分類
- 2024 秋季PAT認證甲級(題解A1-A4)
- 【PAT甲級A1038】Recover the Smallest Number (30分)(c++)C++
- PAT甲級1122 Hamiltonian Cycle (25分)|C++實現C++
- PAT甲級1154 Vertex Coloring (25分)|C++實現C++
- CF1455 D. Sequence and Swaps(模擬)
- 2021.9.12週六PAT甲級考試覆盤與總結
- PAT甲級1110 Complete Binary Tree (25分)|C++實現C++
- 19年春季第二題 PAT甲級 1157 Anniversary(25 分)
- PAT-B 1027 列印沙漏 【模擬】
- PAT-B 1058 選擇題 【模擬】
- PAT-B 1061 判斷題【模擬】
- PAT-B 1067 試密碼【模擬】密碼
- PAT-B 1071 小賭怡情【模擬】
- 菜鳥記錄:c語言實現PAT甲級1010--RadixC語言
- 2020年7月第2題 PAT甲級真題 The Judger (25分)
- PAT-B 1054 求平均值 【模擬】
- PAT-B 1072 開學寄語【模擬】
- PAT-B 1081 檢查密碼【模擬】密碼
- PAT-B 1084 外觀數列 【模擬】
- PAT-B 1018 錘子剪刀布 【模擬】
- (非原創)PAT甲級1123 Is It a Complete AVL Tree (30分)|C++實現C++
- PAT-B 1019 數字黑洞【陣列+模擬】陣列