【PAT甲級A1065】A+B and C (64bit) (20分)(c++)

小莊同學發表於2020-11-19

1065 A+B and C (64bit) (20分)

作者:CHEN, Yue
單位:浙江大學
程式碼長度限制:16 KB
時間限制:400 ms
記憶體限制:64 MB

Given three integers A, B and C in [−2​63​​ ,2​63​​ ], you are supposed to tell whether A+B>C.

Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

題意:

判斷長整型數a+b>c?

思路:

當long long超出正限制是會顯示負數(可以想象成環,正的不夠了只能到負的上去湊),超出負限制時會顯示正。(注意這裡一定要定義一個long long的sum,直接用a+b來判斷的話系統會將和自動分配一個適合的變數型別double)。

參考程式碼:

#include <cstdio>
int main() {
    int n;
    scanf("%d",&n);
    long long a,b,c,sum;
    for(int i=0;i<n;i++){
        scanf("%lld%lld%lld",&a,&b,&c);
        sum=a+b;
        printf("Case #%d: ",i+1);
        if(a>0&&b>0&&sum<=0)printf("true\n");
        else if(a<0&&b<0&&sum>=0)printf("false\n");
        else printf("%s\n",sum>c?"true":"false");
    }
    return 0;
}

如有錯誤,歡迎指正

相關文章