【PAT甲級A1065】A+B and C (64bit) (20分)(c++)
1065 A+B and C (64bit) (20分)
作者:CHEN, Yue
單位:浙江大學
程式碼長度限制:16 KB
時間限制:400 ms
記憶體限制:64 MB
Given three integers A, B and C in [−263 ,263 ], you are supposed to tell whether A+B>C.
Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.
Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).
Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
題意:
判斷長整型數a+b>c?
思路:
當long long超出正限制是會顯示負數(可以想象成環,正的不夠了只能到負的上去湊),超出負限制時會顯示正。(注意這裡一定要定義一個long long的sum,直接用a+b來判斷的話系統會將和自動分配一個適合的變數型別double)。
參考程式碼:
#include <cstdio>
int main() {
int n;
scanf("%d",&n);
long long a,b,c,sum;
for(int i=0;i<n;i++){
scanf("%lld%lld%lld",&a,&b,&c);
sum=a+b;
printf("Case #%d: ",i+1);
if(a>0&&b>0&&sum<=0)printf("true\n");
else if(a<0&&b<0&&sum>=0)printf("false\n");
else printf("%s\n",sum>c?"true":"false");
}
return 0;
}
如有錯誤,歡迎指正
相關文章
- PAT甲級1126~1130|C++實現C++
- 【PAT甲級A1084】Broken Keyboard (20分)(c++)C++
- 【PTA甲級、C++簡單解答】1001 A+B Format (20分)C++ORM
- 【PAT甲級A1038】Recover the Smallest Number (30分)(c++)C++
- PAT甲級1122 Hamiltonian Cycle (25分)|C++實現C++
- PAT甲級1154 Vertex Coloring (25分)|C++實現C++
- PAT甲級1110 Complete Binary Tree (25分)|C++實現C++
- (非原創)PAT甲級1123 Is It a Complete AVL Tree (30分)|C++實現C++
- PAT甲級1032 Sharing
- [PAT B] 1011 A+B 和 C
- PAT甲級1030 Travel Plan
- 浙大PAT甲級考試
- PAT-B 1011 A+B 和 C
- PAT甲級1023 Have Fun with Number
- PAT甲級-1015. Reversible Primes (20)
- PAT 甲級 1152 Google Recruitment (20分)GoUI
- 20年春季甲級pat考試
- 夕甲甲——孔乙己之C++版C++
- 菜鳥記錄:c語言實現PAT甲級1010--RadixC語言
- 1007:計算(a+b)×c的值(C C++)C++
- [#181024][PAT Practice] A+B FormatORM
- PAT甲級-1014. Waiting in Line (30)(模擬)AI
- PAT:1001 A+B Format (20分)ORM
- PAT-B 1016 部分A+B
- PAT甲級真題1069 數字黑洞(巧妙解法)
- PAT甲級考試題庫題目分類
- 【PAT乙級、C++】1024 科學計數法 (20分)C++
- 2024 秋季PAT認證甲級(題解A1-A4)
- PAT甲級-1140. Look-and-say Sequence (20)(模擬)
- PAT-B 1093 字串A+B 【集合】字串
- PAT1013數素數C++C++
- 2021.9.12週六PAT甲級考試覆盤與總結
- 19年春季第二題 PAT甲級 1157 Anniversary(25 分)
- PAT答案(D進位制的A+B)
- PAT乙 1041 考試座位號 (15分)(C C++)C++
- 2020年7月第2題 PAT甲級真題 The Judger (25分)
- PAT(甲級)2020年秋季考試 7-1 Panda and PP Milk (20分)
- C++ 測試框架 GoogleTest 初學者入門篇 甲C++框架Go