【PAT甲級A1065】A+B and C (64bit) (20分)(c++)
1065 A+B and C (64bit) (20分)
作者:CHEN, Yue
單位:浙江大學
程式碼長度限制:16 KB
時間限制:400 ms
記憶體限制:64 MB
Given three integers A, B and C in [−263 ,263 ], you are supposed to tell whether A+B>C.
Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.
Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).
Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
題意:
判斷長整型數a+b>c?
思路:
當long long超出正限制是會顯示負數(可以想象成環,正的不夠了只能到負的上去湊),超出負限制時會顯示正。(注意這裡一定要定義一個long long的sum,直接用a+b來判斷的話系統會將和自動分配一個適合的變數型別double)。
參考程式碼:
#include <cstdio>
int main() {
int n;
scanf("%d",&n);
long long a,b,c,sum;
for(int i=0;i<n;i++){
scanf("%lld%lld%lld",&a,&b,&c);
sum=a+b;
printf("Case #%d: ",i+1);
if(a>0&&b>0&&sum<=0)printf("true\n");
else if(a<0&&b<0&&sum>=0)printf("false\n");
else printf("%s\n",sum>c?"true":"false");
}
return 0;
}
如有錯誤,歡迎指正
相關文章
- 【PAT甲級A1084】Broken Keyboard (20分)(c++)C++
- 【PAT甲級A1038】Recover the Smallest Number (30分)(c++)C++
- 【PTA甲級、C++簡單解答】1001 A+B Format (20分)C++ORM
- PAT甲級1154 Vertex Coloring (25分)|C++實現C++
- PAT甲級1122 Hamiltonian Cycle (25分)|C++實現C++
- PAT 甲級 1152 Google Recruitment (20分)GoUI
- PAT甲級1110 Complete Binary Tree (25分)|C++實現C++
- PAT甲級1126~1130|C++實現C++
- (非原創)PAT甲級1123 Is It a Complete AVL Tree (30分)|C++實現C++
- PAT甲級考試題庫題目分類
- 【PAT乙級、C++】1024 科學計數法 (20分)C++
- PAT甲級-1005. Spell It Right (20)各位之和
- PAT甲級1023 Have Fun with Number
- 2024 秋季PAT認證甲級(題解A1-A4)
- PAT乙 1041 考試座位號 (15分)(C C++)C++
- PAT答案(D進位制的A+B)
- 2021.9.12週六PAT甲級考試覆盤與總結
- 菜鳥記錄:c語言實現PAT甲級1010--RadixC語言
- PAT甲級-1010. Radix (25)進位制
- PAT甲級-1012. The Best Rank (25)並列排序排序
- PAT乙級1004 成績排名 (20分)(C語言版)及解析C語言
- PAT-B 1093 字串A+B 【集合】字串
- 1007:計算(a+b)×c的值(C C++)C++
- PAT甲級-1014. Waiting in Line (30)(模擬)AI
- PAT1013數素數C++C++
- PAT 乙級 1094 谷歌的招聘 (20分)---【素數 字串】谷歌字串
- PTA甲級 1076 Forwards on Weibo (30分)Forward
- C++分類C++
- C++ 測試框架 GoogleTest 初學者入門篇 甲C++框架Go
- (C++)二分C++
- 1022 D進位制的A+B (20分)
- PAT-B 1022 D進位制的A+B【進位制】
- c++ 二分答案C++
- 班級問題(c++)C++
- L1-056 猜數字 (20分) C++C++
- HDU 2033 : 人見人愛A+B (C語言)C語言
- C++和c語言的分別C++C語言
- 7-20 奧運排行榜 (25分)(c++ STL)C++