PTA甲級——Be Unique

-白羊-發表於2020-11-19

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.
Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by N bets. The numbers are separated by a space.
Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.
Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

題目大意:給出序列的長度和一個數字序列,輸出序列中第一個只出現一次的數字,如果不存在則輸出None。

類似於桶排序,可以使用一個陣列直接記錄每個數字出出現的次數,(如果數字過大,會造成大量的記憶體浪費,可以使用雜湊表),然後順序遍歷序列查詢。(如果不想要一個相同的數字被多次和查詢,可以使用set來優化)
程式碼實現:

#include <iostream>
using namespace std;

int times[10005], num[10005]; 

int main()
{
	int t, temp, bit, sign = 0, cnt = 0;

	cin >> t;
	while (t--)
	{
		cin >> temp;
		if (times[temp] == 0) { num[cnt++] = temp; times[temp]++; }
		else times[temp]++;
	}

	for (int i = 0; i < cnt; i++) 
	{ 
		if (times[num[i]] == 1) 
		{ 
			cout << num[i]; 
			sign = 1; 
			break; 
		} 
	}
	if (!sign) cout << "none";
	return 0;
}

相關文章