HDU - 3790 (雙標準限制最短路徑)最短路徑問題

hehedad發表於2018-04-11

         最短路徑問題 HDU 3790
 

給你n個點,m條無向邊,每條邊都有長度d和花費p,給你起點s終點t,要求輸出起點到終點的最短距離及其花費,如果最短距離有多條路線,則輸出花費最少的。
Input輸入n,m,點的編號是1~n,然後是m行,每行4個數 a,b,d,p,表示a和b之間有一條邊,且其長度為d,花費為p。最後一行是兩個數 s,t;起點s,終點。n和m為0時輸入結束。 
(1<n<=1000, 0<m<100000, s != t)Output輸出 一行有兩個數, 最短距離及其花費。Sample Input
3 2
1 2 5 6
2 3 4 5
1 3
0 0
Sample Output
9 11
          這是一道加了限制的最短路徑題~~其實就是在普通的最短路徑的搜尋中多加了幾個關於cost消費的判斷而已~~以路徑最短的優先~~相同的話就以消費最少優先。

#include<cstdio>
#include<queue>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
int m,n;
struct fuck
{
	int to;
	int len;
	int cos;
	int ne;
}ed[100005];
int head[1005];
int cnt = 0;
int vis[1005];
int d[1005];
int cost[1005];
void add(int from, int to, int len, int cos)
{
	ed[cnt].to = to;
	ed[cnt].len = len;
	ed[cnt].cos = cos;
	ed[cnt].ne = head[from];
	head[from] = cnt++;
}
void spfa(int x)
{
	vis[x] = 1;
	queue<int>q;
	q.push(x);
	d[x] = 0;
	cost[x] = 0;
	while (!q.empty())
	{
		int t = q.front();
		q.pop();
		for (int s = head[t]; ~s; s = ed[s].ne)
		{
			if (d[ed[s].to] > d[t] + ed[s].len)
			{
				d[ed[s].to] = d[t] + ed[s].len;
				cost[ed[s].to] = cost[t] + ed[s].cos;
				if (!vis[ed[s].to])
				{
					vis[ed[s].to] = 1;
					q.push(ed[s].to);
				}
			}
			else if (d[ed[s].to] == d[t] + ed[s].len)
			{
				cost[ed[s].to] = min(cost[ed[s].to], cost[t] + ed[s].cos);
			}
		}
		vis[t] = 0;
	}
}
void init()
{
	memset(head, -1, sizeof(head));
	for (int s = 1; s <= n; s++)
	{
		cost[s] = inf;
	}
	for (int s = 1; s <= n; s++)
	{
		d[s] = inf;
	}
	memset(vis, 0, sizeof(vis));
	cnt = 0;
	for (int s = 1; s <= n; s++)
	{
		head[s] = -1;
	}
}
int main()
{
	while (cin >> n >> m&&n+m)
	{
		init();
		while (m--)
		{
			int a, b, c, d;
			scanf("%d%d%d%d", &a, &b, &c, &d);
			add(a, b, c, d);
			add(b, a, c, d);
		}
		int a, b;
		cin >> a >> b;
	//	cout << d[b] << " " << cost[b] << endl;
		spfa(a);
		cout << d[b] << " " << cost[b] << endl;
	}
	return 0;
}




相關文章