hdu 2665 可持久化線段樹求區間第K大值(函式式線段樹||主席樹)
http://acm.hdu.edu.cn/showproblem.php?pid=2665
Problem Description
Give you a sequence and ask you the kth big number of a inteval.
Input
The first line is the number of the test cases.
For each test case, the first line contain two integer n and m (n, m <= 100000), indicates the number of integers in the sequence and the number of the quaere.
The second line contains n integers, describe the sequence.
Each of following m lines contains three integers s, t, k.
[s, t] indicates the interval and k indicates the kth big number in interval [s, t]
For each test case, the first line contain two integer n and m (n, m <= 100000), indicates the number of integers in the sequence and the number of the quaere.
The second line contains n integers, describe the sequence.
Each of following m lines contains three integers s, t, k.
[s, t] indicates the interval and k indicates the kth big number in interval [s, t]
Output
For each test case, output m lines. Each line contains the kth big number.
Sample Input
1
10 1
1 4 2 3 5 6 7 8 9 0
1 3 2
Sample Output
2
/**
hdu 2665 可持久化線段樹求區間第K大值(函式式線段樹||主席樹)
題目大意;給定一個區間,m個詢問:指定區間的第k大的數
解題思路:所謂主席樹,就是可持久化線段樹,也就是說我們每插入了一個新的元素,就創造了一個新的結點,這樣下去,
線段樹所有的歷史版本我們就都能儲存下來。然後考慮一下線段樹相減,兩棵線段樹相減就是每一個結點相減,
那麼我們每一個結點更新一次,那麼序列中每一個元素都對應了一個版本的線段樹,也就是序列中所有的字首的
權值線段樹,那麼對於一個區間,通過字首相減很快就能搞出來這個區間對應的線段樹,然後詢問這棵線段樹的第K大值
注:如果求區間第k小值轉化為第(l-r-k+1)大值就可以了
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
const int N=100010;
int T[N];
int num[N];
int san[N];
int ls[N*20];
int rs[N*20];
int sum[N*20];
int tot,rt;
int n,m;
void build(int l,int r,int &rt)
{
rt=++tot;
sum[rt]=0;
if(l==r)return;
int m=(l+r)/2;
build(l,m,ls[rt]);
build(m+1,r,rs[rt]);
}
void update(int last,int p,int l,int r,int &rt)
{
rt=++tot;
ls[rt]=ls[last];
rs[rt]=rs[last];
sum[rt]=sum[last]+1;
if(l==r)
return;
int m=(l+r)>>1;
if(p<=m)
update(ls[last],p,l,m,ls[rt]);
else
update(rs[last],p,m+1,r,rs[rt]);
}
int query(int ss,int tt,int l,int r,int k)
{
if(l==r)return l;
int m=(l+r)>>1;
int cnt=sum[ls[tt]]-sum[ls[ss]];
if(k<=cnt)
return query(ls[ss],ls[tt],l,m,k);
else
return query(rs[ss],rs[tt],m+1,r,k-cnt);
}
int main()
{
int tt;
scanf("%d",&tt);
while(tt--)
{
scanf("%d%d",&n,&m);
for(int i=1; i<=n; i++)
{
scanf("%d",&num[i]);
san[i]=num[i];
}
tot=0;
sort(san+1,san+n+1);
int cnt=unique(san+1,san+n+1)-san-1;
build(1,cnt,T[0]);
for(int i=1; i<=n; i++)
{
num[i]=lower_bound(san+1,san+1+cnt,num[i])-san;
}
for(int i=1; i<=n; i++)update(T[i-1],num[i],1,cnt,T[i]);
while(m--)
{
int l,r,k;
scanf("%d%d%d",&l,&r,&k);
int id=query(T[l-1],T[r],1,cnt,k);
printf("%d\n",san[id]);
}
}
return 0;
}
相關文章
- 區間k小值(可持久化線段樹)持久化
- 演算法隨筆——主席樹(可持久化線段樹)演算法持久化
- 可持久化線段樹持久化
- 【主席樹】P3919 【模板】可持久化線段樹 1持久化
- 可持久化線段————主席樹(洛谷p3834)持久化
- HDU 1754 I Hate It (線段樹 區間最值)
- 洛谷 P3919 可持久化線段樹 1 之主席樹模板(初級)持久化
- 「學習筆記」可持久化線段樹筆記持久化
- 線段樹 transformation——hdu 4578ORM
- HDU 1698 Just a Hook (線段樹區間更新)Hook
- 【資料結構】可持久化線段樹初步資料結構持久化
- P3834 【模板】可持久化線段樹 2持久化
- 權值線段樹
- hihocoder 1078 線段樹的區間修改 (線段樹 區間更新 模板)
- hdu 1754 I Hate It (線段樹)
- 線~段~樹
- 線段樹
- hdu 4836 The Query on the Tree(線段樹or樹狀陣列)陣列
- Transformation HDU - 4578線段樹綜合操作ORM
- hdu 1754 【線段樹/RMQ】I Hate ItMQ
- hdu 3973 字串hash+線段樹字串
- hdu4288 離線處理線段樹
- HDU 1556 Color the ball(線段樹|樹狀陣列)陣列
- 線段樹(3)——區間操作疊加
- 線段樹 hate it
- 【模版】線段樹
- 01 線段樹
- 線段樹--RMQMQ
- 李超線段樹
- 線段樹模板
- HDU 1754 I Hate It 線段樹入門
- 線段樹維護區間等差數列
- 線段樹筆記筆記
- 線段樹入門
- 線段樹進階
- HDU1698 Just a Hook【線段樹基礎:區間修改+區間查詢】Hook
- POJ 3468 【區間修改+區間查詢 樹狀陣列 | 線段樹 | 分塊】陣列
- 芻議線段樹 2 (區間修改,區間查詢)