POJ 2891-trange Way to Express Integers(解線性同餘方程組)

kewlgrl發表於2016-08-03
Strange Way to Express Integers
Time Limit: 1000MS   Memory Limit: 131072K
Total Submissions: 13819   Accepted: 4451

Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

Choose k different positive integers a1a2…, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1a2, …, ak are properly chosen, m can be determined, then the pairs (airi) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers airi (1 ≤ i ≤ k).

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input

2
8 7
11 9

Sample Output

31

Hint

All integers in the input and the output are non-negative and can be represented by 64-bit integral types.

Source


題目意思:

有多組測試資料,每組先給出一個N,表示該組有N個線性同餘方程。
對每一組測試資料,求解一個M滿足:M≡Ri(mod Ai)

解題思路:

模板題,線性同餘方程組套一個擴充歐幾里得。
/*
* Copyright (c) 2016, 煙臺大學計算機與控制工程學院
* All rights reserved.
* 檔名稱:exgcd.cpp
* 作    者:單昕昕
* 完成日期:2016年4月2日
* 版 本 號:v1.0
*/
#include<iostream>
#include<cstring>
#include<cstdio>
#include<malloc.h>
using namespace std;
typedef long long ll;

ll exgcd(ll a,ll b,ll& x,ll& y)//擴充歐幾里得
{
    if(b==0)
    {
        x=1;
        y=0;
        return a;  //d=a,x=1,y=0,此時等式d=ax+by成立
    }
    ll d=exgcd(b,a%b,y,x);
    y-=x*(a/b); //係數x、y的取值是為滿足等式d=ax+by
    return d;
}

ll solve(ll n)//解同餘方程組
{
    ll a1,a2,r1,r2,x0,y0;
    bool ifhave=true;
    cin>>a1>>r1;
    for(int i=1; i<n; ++i)
    {
        cin>>a2>>r2;
        ll a=a1,b=a2,c=r2-r1;
        ll d=exgcd(a,b,x0,y0);
        if(c%d!=0) ifhave=false;
        int t=b/d;
        x0=(x0*(c/d)%t+t)%t;
        r1=a1*x0+r1;
        a1=a1*(a2/d);
    }
    if(!ifhave) r1=-1;
    return r1;
}

int main()
{
    ll t;
    while(cin>>t)
    {
        cout<<solve(t)<<endl;
    }
    return 0;
}
/**
2
8 7
11 9
**/


相關文章