POJ-2527 Polynomial Remains-多項式相除
Polynomial Remains
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 1240 | Accepted: 702 |
Description
Given the polynomial
a(x) = an xn + ... + a1 x + a0,
compute the remainder r(x) when a(x) is divided by xk+1.
compute the remainder r(x) when a(x) is divided by xk+1.
Input
The input consists of a number of cases. The first line of each case specifies the two integers n and k (0 <= n, k <= 10000). The next n+1 integers give the coefficients of a(x), starting from a0 and ending with an. The input is
terminated if n = k = -1.
Output
For each case, output the coefficients of the remainder on one line, starting from the constant coefficient r0. If the remainder is 0, print only the constant coefficient. Otherwise, print only the first d+1 coefficients for a
remainder of degree d. Separate the coefficients by a single space.
You may assume that the coefficients of the remainder can be represented by 32-bit integers.
You may assume that the coefficients of the remainder can be represented by 32-bit integers.
Sample Input
5 2 6 3 3 2 0 1 5 2 0 0 3 2 0 1 4 1 1 4 1 1 1 6 3 2 3 -3 4 1 0 1 1 0 5 1 0 0 7 3 5 1 2 3 4 -1 -1
Sample Output
3 2 -3 -1 -2 -1 2 -3 0 0 1 2 3 4
Source
Alberta Collegiate Programming Contest 2003.10.18
因為輸入輸出資料太多,所以用cin、cout會超時。。
#include <iostream>
#include <cstdio>
using namespace std;
const int maxn = 10010;
int main()
{
int n,k;
int val[maxn];
while(scanf("%d%d",&n,&k)!=EOF,n!=-1 || k !=-1)
{
int i;
for(i = 0 ; i <= n ; ++i)
{
scanf("%d",&val[i]);
}
//進行除法運算
for(i = n ; i >= k ; --i)
{
if(val[i] == 0)
{
continue;
}
val[i-k] = val[i-k] - val[i];
val[i] = 0;
}
//調整陣列長度,即高位的0不用輸出
int t = n;
while(val[t] == 0 && t > 0)
{
--t;
}
for(i = 0 ; i < t ; ++i)
{
printf("%d ",val[i]);
}
printf("%d\n",val[t]);
}
return 0;
}
因為輸入輸出資料太多,所以用cin、cout會超時。。
相關文章
- [Step By Step]SAP HANA PAL多項式迴歸預測分析Polynomial Regression程式設計例項POLYNOMIALREGRESSION(模型)...程式設計模型
- 多項式
- 多項式乘法
- 多項式全家桶
- 生成函式與多項式函式
- 【模板】多項式乘法逆
- 一元多項式操作
- 多項式學習筆記筆記
- BZOJ 3456: 城市規劃 [多項式求逆元 組合數學 | 生成函式 多項式求ln]函式
- 36:計算多項式的值
- 實現多項式的JAVA類Java
- 普通有限多項式筆記筆記
- 核函式 多項式核函式 高斯核函式(常用)函式
- 【組合數學】多項式定理 ( 多項式係數 | 多重集全排列 | 對應放球子模型方案數 | 多項式係數相關恆等式 )模型恆等式
- 正交多項式介紹及應用
- 【機器學習】多項式迴歸原理介紹機器學習
- 【機器學習】多項式迴歸sklearn實現機器學習
- 一元多項式的應用
- 輾轉相除法原理
- PostgreSQL整型相除規範SQL
- 【機器學習】多項式迴歸python實現機器學習Python
- Tensorflow教程(前二)——多項式迴歸
- 15.6 用多項式一致逼近連續函式函式
- 手擼機器學習演算法 - 多項式迴歸機器學習演算法
- 用多項式的逆優化dp總結優化
- 特徵工程:互動特徵與多項式特徵理解特徵工程
- MATLAB求多項式係數及次數Matlab
- CF156D-Prufer序列、多項式定理
- 使用梯度下降法實現多項式迴歸梯度
- 輾轉相除法的原理
- [ABC137F] Polynomial Construction 題解Struct
- 題解 P10249【【模板】多項式複合函式】函式
- 數論函式群在數論多項式生成函式集上的作用函式
- java的多項式的加減乘除和賦值Java賦值
- 多程式程式設計函式posix_spawn例項程式設計函式
- 演化計算(例項:多峰函式最值) (轉)函式
- 有標號的二分圖計數 [生成函式 多項式]函式
- 透徹理解輾轉相除法