HDU 1020 Encoding

淡定的小魚發表於2014-07-28

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26148    Accepted Submission(s): 11511


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

Output
For each test case, output the encoded string in a line.
 

Sample Input
2 ABC ABBCCC
 

Sample Output
ABC A2B3C
 



感覺這題怪怪的


#include<stdio.h>
#include<string.h>
char a[11000];
int main()
{
	int n,i,j,k;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%s",a);
		for(i=0;a[i]!='\0';i++)
		{
			for(j=i,k=0;j<strlen(a);k++,j++)
			{
				if(a[i]!=a[j])
				break;
			}
			if(k>1)
			printf("%d",k);
			printf("%c",a[i]);
			i=j-1;        //把 i 限制到第二個for迴圈處 j 所處的位置 
		}
		printf("\n");
	}
	return 0;
}
	




相關文章