bzoj 2120

weixin_30924079發表於2020-04-04

2120: 數顏色

Time Limit: 6 Sec  Memory Limit: 259 MB
Submit: 5161  Solved: 2065
[Submit][Status][Discuss]

Description

墨墨購買了一套N支彩色畫筆(其中有些顏色可能相同),擺成一排,你需要回答墨墨的提問。墨墨會像你釋出如下指令: 1、 Q L R代表詢問你從第L支畫筆到第R支畫筆中共有幾種不同顏色的畫筆。 2、 R P Col 把第P支畫筆替換為顏色Col。為了滿足墨墨的要求,你知道你需要幹什麼了嗎?

Input

第1行兩個整數N,M,分別代表初始畫筆的數量以及墨墨會做的事情的個數。第2行N個整數,分別代表初始畫筆排中第i支畫筆的顏色。第3行到第2+M行,每行分別代表墨墨會做的一件事情,格式見題幹部分。

Output

對於每一個Query的詢問,你需要在對應的行中給出一個數字,代表第L支畫筆到第R支畫筆中共有幾種不同顏色的畫筆。

Sample Input

6 5
1 2 3 4 5 5
Q 1 4
Q 2 6
R 1 2
Q 1 4
Q 2 6

Sample Output

4
4
3
4

HINT

 

對於100%的資料,N≤10000,M≤10000,修改操作不多於1000次,所有的輸入資料中出現的所有整數均大於等於1且不超過10^6。


2016.3.2新加資料兩組by Nano_Ape

 

待修改的莫隊

讓查詢與修改操作分離

#include<cmath>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define K 2000001
#define N 10001
#define M 1001
using namespace std;
int n,m,siz,now,tot,tmp;
int col[K],sum[K],original[K];
struct QUERY
{
    int l,r,bl,id,ans;
    int tim;    
}e[N];
struct CNANGE
{
    int before,after,pos;
}ch[M];
bool cmp1(QUERY q,QUERY p)
{
    if(q.bl!=p.bl) return q.bl<p.bl;
    if(q.r!=p.r) return q.r<p.r;
    return q.tim<p.tim;
}
bool cmp2(QUERY q,QUERY p)
{
    return q.id<p.id;
}
void update(int to,int w)
{
    sum[to]+=w;
    if(w==1 && sum[to]==1) tmp++;
    if(w==-1 && !sum[to]) tmp--;
}
int main()
{
    scanf("%d%d",&n,&m);
    siz=sqrt(n);
    for(int i=1;i<=n;i++) scanf("%d",&col[i]),original[i]=col[i];
    char c[2]; int l,r;
    while(m--)
    {
        scanf("%s%d%d",c,&l,&r);
        if(c[0]=='Q')
        {
            ++tot;
            e[tot].l=l; e[tot].r=r; e[tot].id=tot; e[tot].bl=(l-1)/siz+1;
            e[tot].tim=now;
        }
        else ch[++now].after=r,ch[now].pos=l;
    }
    sort(e+1,e+tot+1,cmp1);
    int L=1,R=0; now=0;
    for(int i=1;i<=tot;i++)
    {
        while(now<e[i].tim)
        {
            now++;
            ch[now].before=col[ch[now].pos];
            if(ch[now].pos>=L&&ch[now].pos<=R) update(ch[now].before,-1),update(ch[now].after,1);
            col[ch[now].pos]=ch[now].after;
        }
        while(now>e[i].tim)
        {
            if(ch[now].pos>=L&&ch[now].pos<=R) update(ch[now].after,-1),update(ch[now].before,1);
            col[ch[now].pos]=ch[now].before;
            now--;
        }
        while(L<e[i].l) update(col[L++],-1);
        while(L>e[i].l) update(col[--L],1);
        while(R<e[i].r) update(col[++R],1);
        while(R>e[i].r) update(col[R--],-1); 
        e[i].ans=tmp;
    }
    sort(e+1,e+tot+1,cmp2);
    for(int i=1;i<=tot;i++) printf("%d\n",e[i].ans);
    return 0;
}

 

轉載於:https://www.cnblogs.com/TheRoadToTheGold/p/7056383.html