POJ1511 Invitation Cards【Dijkstra+堆優化+前向星】
Invitation Cards
Time Limit: 8000MS | Memory Limit: 262144K | |
Total Submissions: 33768 | Accepted: 11206 |
Description
In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.
The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.
All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.
Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.
Output
For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.
Sample Input
2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50
Sample Output
46
210
Source
問題描述:有n個公交站,m條公交線路,公交線路是單向的,a,b,s描述一條公交線,表示從公交站a到公交站b需要s錢。早上n-1個學生從1號公交站乘車分別送到2~n-1號公交站,晚上這些學生再乘車回1號公交站。問花費的錢最少為多少
解題思路:實際是求1號公交站到其他各站的最短路徑+各個站到1號站的最短路徑。前者好求,可以使用Dijkstra演算法,而要求後者就有一個技巧了,就是讓圖反向,然後再求1號公交站到其他各個站的最短路徑,那麼這個最短路徑也就對應於原圖各個站到1號站的最短路徑了。Dijkstra+堆優化+vector也會超時,問題出在vector上,要使用前先星實現圖的鄰接表。Dijkstra+堆優化+前向星
AC的C++程式碼:
#include<iostream>
#include<vector>
#include<queue>
#include<cstring>
using namespace std;
const int N=1000005;
const int INF=0x3f3f3f3f;
int dist[N];
bool vis[N];
//前向星實現圖的鄰接表
int M1,M2;
int head1[N];
int head2[N];
struct Edge{
int to,next,w;
}g1[N],g2[N];
void add1(int from,int to,int w)
{
g1[M1].next=head1[from],g1[M1].to=to,g1[M1].w=w;
head1[from]=M1++;
}
void add2(int from,int to,int w)
{
g2[M2].next=head2[from],g2[M2].to=to,g2[M2].w=w;
head2[from]=M2++;
}
struct Node{
int u,w;
Node(){}
Node(int u,int w):u(u),w(w){}
bool operator<(const Node &a)const
{
return w>a.w;
}
};
void dijkstra(int s,int head[],Edge g[])//s表示起點,g表示相應的鄰接表
{
memset(dist,INF,sizeof(dist));
memset(vis,false,sizeof(vis));
priority_queue<Node>q;
q.push(Node(s,0));
dist[s]=0;
while(!q.empty()){
Node f=q.top();
q.pop();
int u=f.u;
if(!vis[u]){
vis[u]=true;
for(int i=head[u];i!=-1;i=g[i].next){
int v=g[i].to;
if(!vis[v]){
if(dist[v]>dist[u]+g[i].w){
dist[v]=dist[u]+g[i].w;
q.push(Node(v,dist[v]));
}
}
}
}
}
}
int main()
{
int T,n,m,a,b,c;
scanf("%d",&T);
while(T--){
scanf("%d%d",&n,&m);
memset(head1,-1,sizeof(head1));
memset(head2,-1,sizeof(head2));
M1=M2=0;
while(m--){
scanf("%d%d%d",&a,&b,&c);
add1(a,b,c);//存原圖
add2(b,a,c);//存反圖
}
long long res=0;
dijkstra(1,head1,g1);//計算1號站到其他站的最短路徑
for(int i=1;i<=n;i++)
res+=dist[i];
dijkstra(1,head2,g2); //計算其他站到1號站的最短路徑
for(int i=1;i<=n;i++)
res+=dist[i];
printf("%lld\n",res);
}
return 0;
}
相關文章
- POJ 1511-Invitation Cards(SPFA)
- POJ 2387-Til the Cows Come Home(Dijkstra+堆優化)優化
- POJ 1511 Invitation Cards(最短路spfa演算法)演算法
- 鏈式前向星介紹以及原理
- 優化星型查詢優化
- 利用Decorator和SourceMap優化JavaScript錯誤堆疊優化JavaScript
- QPM 準備優化前的思考優化
- 堆--優先佇列佇列
- SQL優化(3)(延續前一節)SQL優化
- Oracle優化器:星型轉換(Star Query Transformation )Oracle優化ORM
- 堆與優先佇列佇列
- 堆和優先佇列佇列
- 前臺頁面優化全攻略(一)優化
- 前臺頁面優化全攻略(四)優化
- 三向切分的快速排序和優化排序優化
- HMM-前向後向演算法HMM演算法
- 堆和堆的應用:堆排序和優先佇列排序佇列
- 向OTA看齊酒店應如何優化數字化體驗?優化
- 為何物件導向優於結構化? (轉)物件
- 圖的深度優先遍歷[非堆疊、堆疊實現]
- 前後端不分離到分離演變,優勢,前後端介面聯調,排錯及優化後端優化
- 二叉堆優先佇列佇列
- 堆——神奇的優先佇列(上)佇列
- BZOJ4388 : JOI2012 invitation
- 前向渲染和延遲渲染
- POJ 1556 The Doors(Dijkstra+計算幾何)
- 最短路-樸素版Dijkstra演算法&堆優化版的Dijkstra演算法優化
- java使用PriorityQueue即優先佇列實現大根堆和小根堆Java佇列
- D3.js 力導向圖的顯示優化JS優化
- 優化向:單頁應用多路由預渲染指南優化路由
- 隱馬爾科夫模型前向後向演算法馬爾科夫模型演算法
- CUDA教學(1):前向轉播
- Oracle 星型模式的調優Oracle模式
- 【Lintcode】1728. X of a Kind in a Deck of Cards
- CARDS主題 & 導航欄樣式修改
- 【Spark篇】---Spark調優之程式碼調優,資料本地化調優,記憶體調優,SparkShuffle調優,Executor的堆外記憶體調優Spark記憶體
- 圖的深度優先遍歷(堆疊實現和非堆疊實現)
- 在SpringBoot中使用logback優化異常堆疊的輸出Spring Boot優化