POJ 3249-Test for Job(拓撲排序&&DP)

kewlgrl發表於2016-05-03

Test for Job

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 10339   Accepted: 2405

Description

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It's hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.

The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.

In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit Vi of all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input

The input file includes several test cases.
The first line of each test case contains 2 integers n and m(1 ≤ n ≤ 100000, 0 ≤ m ≤ 1000000) indicating the number of cities and roads.
The next n lines each contain a single integer. The ith line describes the net profit of the city i, Vi (0 ≤ |Vi| ≤ 20000)
The next m lines each contain two integers x, y indicating that there is a road leads from city x to city y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city.

Output

The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)

Sample Input

6 5
1
2
2
3
3
4
1 2
1 3
2 4
3 4
5 6

Sample Output

7

Hint

Source

POJ Monthly--2007.07.08, 落葉飛雪

題目意思:

一個人去找工作,面試官給了他這道題:
給出一些城市與城市之間的道路,每到達一個城市,就會獲得一些收益或是損失,求最大收益。


解題思路:

資料量巨大!
用鏈式前向星方式儲存路徑,拓撲排序後,再使用用DAG單源最短路演算法。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
#define inf 2000000010
#define Maxn 100010
#define Maxm 1000010
using namespace std;
int n,i,j,e,num,Max;
int dist[Maxn],head[Maxn];//儲存儲存描述點vi邊資訊的鏈的起點在Edges陣列的位置
int value[Maxn],indegree[Maxn],outdegree[Maxn];//點值和入度出度
int ans[Maxn];//拓撲序列
struct Edge
{
    //鏈式前向星 將新加入的節點鏈在對應鏈的最開始並修改head陣列的對應位置的值
    int to;//終點
    int val;//權值
    int next;//指向下一條邊
} edge[Maxm];

void init()//初始化
{
    memset(indegree,0,sizeof(indegree));
    memset(outdegree,0,sizeof(outdegree));
    memset(head,-1,sizeof(head));
    memset(ans,0,sizeof(ans));
    for(int i=0; i<=100010; i++)
        dist[i]=-inf;
    Max=-inf;
    e=0;
    num=1;
}

void addedge(int from,int to,int val)
{
    edge[e].to=to;
    edge[e].val=val;
    edge[e].next=head[from];
    head[from]=e++;
}

void Topsort()//拓撲排序
{
    queue<int> q;
    int now,adj;
    for(i=1; i<=n; i++)
    {
        if(indegree[i]==0)
        {
            q.push(i);
            dist[i]=value[i];
        }
    }
    while(!q.empty())
    {
        now=q.front();
        ans[num++]=now;
        q.pop();
        for(i=head[now]; i!=-1; i=edge[i].next)
        {
            adj=edge[i].to;
            indegree[adj]--;
            if(!indegree[adj])
                q.push(adj);
        }
    }
}

void DAG()//DAG單源最短路
{
    for(i=1; i<num; i++)
    {
        for(j=head[ans[i]]; j!=-1; j=edge[j].next)
        {
            dist[edge[j].to]=max(dist[edge[j].to],dist[ans[i]]+edge[j].val);
        }
        if(outdegree[ans[i]]==0)
        {
            if(dist[ans[i]]>Max)
                Max=dist[ans[i]];
        }
    }
}

int main()
{
    int m,i,a,b;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        init();
        for(i=1; i<=n; i++)
            scanf("%d",&value[i]);
        for(i=1; i<=m; i++)
        {
            scanf("%d%d",&a,&b);
            addedge(a,b,value[b]);
            indegree[b]++,outdegree[a]++;
        }
        Topsort();
        DAG();
        printf("%d\n",Max);
    }
    return 0;
}


相關文章