Reward (圖論+拓撲排序)
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
Sample Input
2 1 1 2 2 2 1 2 2 1
Sample Output
1777 -1
#include <iostream>
#include<cstdio>
#include<queue>
#include<vector>
using namespace std;
const int maxn=11000;
int n,m,ans[maxn],r[maxn];
vector <vector<int> >v;
void input(){
v.clear();
v.resize(n+1);
for(int i=0;i<=n;i++)
{
ans[i]=-1;
r[i]=0;
}
int a,b;
while(m-->0)
{
scanf("%d%d",&a,&b);
v[b].push_back(a);
r[a]++;
}
}
void solve(){
queue <int> q;
for(int i=1;i<=n;i++)
{
if(r[i]==0)q.push(i);//將沒有依賴頂點的結點入隊
}
int tmp=888;
while(!q.empty())
{
int qsize=q.size();
while(qsize--)
{
int s=q.front();
q.pop();
ans[s]=tmp;
for(int i=0;i<v[s].size();i++)
{
int d=v[s][i];
r[d]--;
if(r[d]==0)q.push(d);
}
}
tmp++;
}
int sum=0;
for(int i=1;i<=n;i++)
{
if(ans[i]>0)sum+=ans[i];
else{
sum=-1;
break;
}
}
cout<<sum<<endl;
}
int main(){
while(scanf("%d%d",&n,&m)!=EOF)
{
input();
solve();
}
return 0;
}
相關文章
- 圖論——拓撲排序圖論排序
- 演算法-圖論-拓撲排序演算法圖論排序
- 拓撲排序排序
- 有向圖的拓撲排序——DFS排序
- 拓撲排序,YYDS排序
- 圖解拓撲排序+程式碼實現圖解排序
- 筆記:拓撲排序筆記排序
- 拓撲排序小結排序
- 圖的拓撲排序詳解與實現排序
- 拓撲排序 (BFS )DAG (有向無環圖)排序
- AOV網與拓撲排序排序
- 【筆記/模板】拓撲排序筆記排序
- DFS實現拓撲排序排序
- 演算法資料結構 | 圖論基礎演算法——拓撲排序演算法資料結構圖論排序
- 拓撲排序就這麼回事排序
- (set+拓撲排序) CF1572A Book排序
- 網路拓撲圖:網路拓撲圖介紹及線上製作
- VOL.2 拓撲排序與關鍵路徑排序
- 【Tarjan 拓撲排序 dp】P3387 【模板】縮點排序
- 團隊拓撲快速參考圖
- vue 實現動態拓撲圖Vue
- 拓撲排序詳解(梅開二度之dfs版按字典序輸出拓撲路徑+dfs版輸出全部拓撲路徑排序
- Noc拓撲
- 洛谷P3953 逛公園(dp 拓撲排序)排序
- 牛客 51011 可達性統計(拓撲排序,bitset)排序
- 【BZOJ-1565】植物大戰殭屍 拓撲排序 + 最小割排序
- Day2 尤拉路,拓撲排序和差分約束排序
- zabbix二次開發整合拓撲圖功能
- Leetcode 1691. 堆疊長方體的最大高度(拓撲排序 + DP)LeetCode排序
- 基於d3.js的關係拓撲圖JS
- StratoVirt 的 vCPU 拓撲(SMP)
- 網路拓撲結構
- BZOJ2535: [Noi2010]Plane 航空管制2(拓撲排序 貪心)排序
- Android程式設計師會遇到的演算法(part 7 拓撲排序)Android程式設計師演算法排序
- C++輸出有向無環圖的所有拓撲序列C++
- 快速建立 HTML5 Canvas 電信網路拓撲圖HTMLCanvas
- 藍橋杯 卡勒沃夫之弱水路三千(提高型) 拓撲排序+Map排序
- Istio全景監控與拓撲