Reward (圖論+拓撲排序)

十二分熱愛發表於2018-08-03

Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards. 
 The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000) 
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.

Output

For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.

Sample Input

2 1
1 2
2 2
1 2
2 1

Sample Output

1777
-1

 

#include <iostream>
#include<cstdio>
#include<queue>
#include<vector>
using namespace std;

const int maxn=11000;
int n,m,ans[maxn],r[maxn];
vector <vector<int> >v;

void input(){
	v.clear();
	v.resize(n+1);
	for(int i=0;i<=n;i++)
	{
		ans[i]=-1;
		r[i]=0;
	}
	int a,b;
	while(m-->0)
	{
		scanf("%d%d",&a,&b);
		v[b].push_back(a);
		r[a]++;
	}
}

void solve(){
	queue <int> q;
	for(int i=1;i<=n;i++)
	{
		if(r[i]==0)q.push(i);//將沒有依賴頂點的結點入隊 
	}
	int tmp=888;
	while(!q.empty())
	{
		int qsize=q.size();
		while(qsize--)
		{
			int s=q.front();
			q.pop();
			ans[s]=tmp;
			for(int i=0;i<v[s].size();i++)
			{
				int d=v[s][i];
				r[d]--;
				if(r[d]==0)q.push(d); 
			}
			
		}
		tmp++;
	 } 
	 int sum=0;
	 for(int i=1;i<=n;i++)
	 {
	 	if(ans[i]>0)sum+=ans[i];
	 	else{
	 		sum=-1;
	 		break;
		 }
	 }
	 cout<<sum<<endl;
}
int main(){
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		input();
		solve();
	}
	return 0;
} 

 

相關文章