POJ 1611 The Suspects 圖論
The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 65828 Accepted: 31101
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
Source
Asia Kaohsiung 2003
題意:求 0 號節點能通往的所有節點數
思路:直接dfs遍歷即可,但要注意該圖為雙向圖
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
const int N = 30005,M = N*500;
int h[N],ne[M],e[M],idx,n,m,ans;
bool st[N];
void add(int a,int b)
{
e[idx] = b,ne[idx] = h[a],h[a] = idx++;
}
void dfs(int u)
{
st[u] = true;
ans++;
for(int i = h[u]; i != -1; i = ne[i])
{
int j = e[i];
if(!st[j]) dfs(j);
}
}
int main()
{
while(cin >> n >> m)
{
if( !n && !m ) break;
memset(h,-1,sizeof h);
memset(st,0,sizeof st);
idx = 0,ans = 0;
for(int i = 0; i < m ; i++)
{
int k,a;
cin >> k;
if(k) cin >> a;
for(int j = 0; j < k - 1; j++)
{
int b;
cin >> b;
add(a,b);//雙向建圖
add(b,a);
a = b;
}
}
dfs(0);
cout << ans << endl;
}
return 0;
}
相關文章
- The Suspects
- The Suspects-並查集(4)並查集
- POJ - 3041 Asteroids 【二分圖匹配】AST
- poj1637 Sightseeing tour(混合圖尤拉回路)
- 圖論圖論
- POJ 1734 Sightseeing trip Floyd求無向圖最小環
- poj 2031
- poj 3461
- 【圖論】尤拉圖圖論
- 10244圖論圖論
- 模板 - 圖論圖論
- 【模板】圖論圖論
- 圖論板子圖論
- poj 3278 BFS
- POJ 2975 Nim
- poj3417
- POJ 1089 Intervals
- POJ 3414 Pots
- 基礎圖論圖論
- 圖論基礎圖論
- 片 - 圖論 - 1圖論
- 圖論筆記圖論筆記
- 圖論題單圖論
- 圖論連通性圖論
- 圖論總結圖論
- 最短路圖論圖論
- 圖論(Graph Theory)圖論Graph Theory
- CQNK圖論 1圖論
- 圖論-有向圖縮點圖論
- ¡Hola Euler! 圖資料庫的理論基礎:圖論資料庫圖論
- Network(POJ-1144)
- POJ 2553 The Bottom of a Graph
- POJ 1861 Network (Kruskal)
- Apple Catching POJ - 2385APP
- POJ 1442 Black Box
- POJ 2799 IP Networks
- POJ3259-WormholesWorm
- POJ3414-Pots