poj 1094 拓撲排序

DlMON發表於2016-03-11

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

解題思路:

本題序列範圍較小隻有26個,而且輸出要求路徑的編號,所以每次新增路徑都進行一次拓撲排序。

這道題wa了很多次,之前沒有想到序列無序後可能會產生環,所以判斷序列無序之後就直接跳出了,這裡要注意。


#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<vector>
#include<queue>
#include<map>
#include<stack>
#include<queue>
#include<algorithm>
using namespace std;
int min(int a,int b)
{
	if(a<b)return a;
	else return b;
}
int max(int a,int b)
{
	if(a>b)return a;
	else return b;
}
int n,m;
int in[30],lines[30];
int maps[30][30];
int topu()
{
	int vis[30],flag=3;
	for(int i=0;i<n;i++)
		vis[i]=in[i];
	for(int pos=0;pos<n;pos++)
	{
	int num=0,x;
	for(int i=0;i<n;i++)
		if(vis[i]==0)
			{
				num++;
				x=i;
			}
	if(num==0)return 1;//有環
	if(num>1)flag=2;//不確定<span style="color:#ff0000;">(注意)</span>
	//if(num==1)
	//{
		vis[x]=-1;
		lines[pos]=x+'A';
		for(int i=0;i<n;i++)
			if(maps[x][i])
				vis[i]--;
	//}
	}
	return flag;//確定序列
}
int main()
{
	//freopen("in.txt","r",stdin);
	//freopen("out.txt","w",stdout);
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(n==0&&m==0)break;
		memset(maps,0,sizeof(maps));
		memset(in,0,sizeof(in));
		memset(lines,0,sizeof(lines));
		int flag1=0;
		for(int j=0;j<m;j++)
		{
			char c[5];
			scanf("%s",c);
			if(flag1==1)
			continue;	
			if(maps[c[0]-'A'][c[2]-'A']==0)
			{
				maps[c[0]-'A'][c[2]-'A']=1;
				in[c[2]-'A']++;
			}
			int flag=topu();
			if(flag==1)
			{
				printf("Inconsistency found after %d relations.\n",j+1);
				flag1=1;
			}
			if(flag==3)
			{
				printf("Sorted sequence determined after %d relations: ",j+1);
				for(int k=0;k<n;k++)
					printf("%c",lines[k]);
				printf(".\n");
				flag1=1;
			}
		}
		if(flag1==0)
			printf("Sorted sequence cannot be determined.\n");
	}
	return 0;
}



相關文章