poj 1094 拓撲排序
Description
An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will
give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
Input
Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of
the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character
"<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output
For each problem instance, output consists of one line. This line should be one of the following three:
Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.
where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.
Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.
where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.
Sample Input
4 6 A<B A<C B<C C<D B<D A<B 3 2 A<B B<A 26 1 A<Z 0 0
Sample Output
Sorted sequence determined after 4 relations: ABCD. Inconsistency found after 2 relations. Sorted sequence cannot be determined.
解題思路:
本題序列範圍較小隻有26個,而且輸出要求路徑的編號,所以每次新增路徑都進行一次拓撲排序。
這道題wa了很多次,之前沒有想到序列無序後可能會產生環,所以判斷序列無序之後就直接跳出了,這裡要注意。
#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<vector>
#include<queue>
#include<map>
#include<stack>
#include<queue>
#include<algorithm>
using namespace std;
int min(int a,int b)
{
if(a<b)return a;
else return b;
}
int max(int a,int b)
{
if(a>b)return a;
else return b;
}
int n,m;
int in[30],lines[30];
int maps[30][30];
int topu()
{
int vis[30],flag=3;
for(int i=0;i<n;i++)
vis[i]=in[i];
for(int pos=0;pos<n;pos++)
{
int num=0,x;
for(int i=0;i<n;i++)
if(vis[i]==0)
{
num++;
x=i;
}
if(num==0)return 1;//有環
if(num>1)flag=2;//不確定<span style="color:#ff0000;">(注意)</span>
//if(num==1)
//{
vis[x]=-1;
lines[pos]=x+'A';
for(int i=0;i<n;i++)
if(maps[x][i])
vis[i]--;
//}
}
return flag;//確定序列
}
int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
while(scanf("%d%d",&n,&m)!=EOF)
{
if(n==0&&m==0)break;
memset(maps,0,sizeof(maps));
memset(in,0,sizeof(in));
memset(lines,0,sizeof(lines));
int flag1=0;
for(int j=0;j<m;j++)
{
char c[5];
scanf("%s",c);
if(flag1==1)
continue;
if(maps[c[0]-'A'][c[2]-'A']==0)
{
maps[c[0]-'A'][c[2]-'A']=1;
in[c[2]-'A']++;
}
int flag=topu();
if(flag==1)
{
printf("Inconsistency found after %d relations.\n",j+1);
flag1=1;
}
if(flag==3)
{
printf("Sorted sequence determined after %d relations: ",j+1);
for(int k=0;k<n;k++)
printf("%c",lines[k]);
printf(".\n");
flag1=1;
}
}
if(flag1==0)
printf("Sorted sequence cannot be determined.\n");
}
return 0;
}
相關文章
- 拓撲排序排序
- 拓撲排序,YYDS排序
- 圖論——拓撲排序圖論排序
- 筆記:拓撲排序筆記排序
- 拓撲排序小結排序
- Reward (圖論+拓撲排序)圖論排序
- AOV網與拓撲排序排序
- 【筆記/模板】拓撲排序筆記排序
- DFS實現拓撲排序排序
- 拓撲排序就這麼回事排序
- 演算法-圖論-拓撲排序演算法圖論排序
- 有向圖的拓撲排序——DFS排序
- (set+拓撲排序) CF1572A Book排序
- 圖解拓撲排序+程式碼實現圖解排序
- 圖的拓撲排序詳解與實現排序
- 拓撲排序 (BFS )DAG (有向無環圖)排序
- VOL.2 拓撲排序與關鍵路徑排序
- 【Tarjan 拓撲排序 dp】P3387 【模板】縮點排序
- 拓撲排序詳解(梅開二度之dfs版按字典序輸出拓撲路徑+dfs版輸出全部拓撲路徑排序
- Noc拓撲
- POJ 1094 Sorting It All Out Floyd_Washall+Topological_sort
- 洛谷P3953 逛公園(dp 拓撲排序)排序
- 牛客 51011 可達性統計(拓撲排序,bitset)排序
- 【BZOJ-1565】植物大戰殭屍 拓撲排序 + 最小割排序
- Day2 尤拉路,拓撲排序和差分約束排序
- Leetcode 1691. 堆疊長方體的最大高度(拓撲排序 + DP)LeetCode排序
- StratoVirt 的 vCPU 拓撲(SMP)
- 網路拓撲結構
- BZOJ2535: [Noi2010]Plane 航空管制2(拓撲排序 貪心)排序
- Android程式設計師會遇到的演算法(part 7 拓撲排序)Android程式設計師演算法排序
- 網路拓撲圖:網路拓撲圖介紹及線上製作
- 藍橋杯 卡勒沃夫之弱水路三千(提高型) 拓撲排序+Map排序
- 演算法資料結構 | 圖論基礎演算法——拓撲排序演算法資料結構圖論排序
- Istio全景監控與拓撲
- 拓撲序的三種功能
- tidb拓撲查詢工具qtidbTiDBQT
- 樹的拓撲序計數
- 網路拓撲—FTP服務搭建FTP
- 拓撲AC NOIP模擬賽2