{A} + {B}
給你兩個集合,要求{A} + {B}.
注:同一個集合中不會有兩個相同的元素.
Input
每組輸入資料分為三行,第一行有兩個數字n,m(0<n,m<=10000),分別表示集合A和集合B的元素個數.後兩行分別表示集合A和集合B.每個元素為不超出int範圍的整數,每個元素之間有一個空格隔開.
Output
針對每組資料輸出一行資料,表示合併後的集合,要求從小到大輸出,每個元素之間有一個空格隔開.
Sample Input
1 2 1 2 3 1 2 1 1 2
Sample Output
1 2 3 1 2
AC碼:
#include<stdio.h>
#include<algorithm>
using namespace std;
const int maxn=10010;
int a[maxn],b[maxn];
const int MAX=20020;
int c[MAX];
int main()
{
int n,m;
while(~scanf("%d %d",&n,&m))
{
int k=0;
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
c[k++]=a[i];
}
for(int i=0;i<m;i++)
{
scanf("%d",&b[i]);
c[k++]=b[i];
}
sort(c,c+k);
printf("%d",c[0]);
for(int i=1;i<k;i++)
{
if(c[i]==c[i-1])
continue;
else
printf(" %d",c[i]);
}
printf("\n");
}
return 0;
}
方法二:
利用set容器去掉重複的,與set的預設排序。
#include<iostream>
#include<set>
using namespace std;
set<int>s;
int main()
{
int n,m,a;
while(cin>>n>>m)
{
for(int i=1;i<=n+m;i++)
{
cin>>a;
s.insert(a);
}
set<int>::iterator it=s.begin();
cout<<*it;
it++;
while(it!=s.end())
{
cout<<" "<<*it;
it++;
}
cout<<endl;
s.clear() ;
}
return 0;
}
相關文章
- 筆記:從Aurora 8b/10b 到Aurora 64b/66b (一):Aurora 8b/10b筆記
- 筆記:從Aurora 8b/10b 到Aurora 64b/66b (一):64b/66b 基本知識筆記
- [PAT B] 1011 A+B 和 C
- PAT-B 1016 部分A+B
- 位(bit/b)、位元組(byte/B)、字元字元
- B2B撮合交易平臺
- PAT-B 1093 字串A+B 【集合】字串
- PAT-B 1011 A+B 和 C
- A與B
- A+B
- B2B2B產業鏈電商平臺解決方案:打造B2B2B系統新模式,解決傳統行業痛點產業模式行業
- B樹與B+樹區別辨析
- 轉載 atan2(a,b) 和 atan(a/b)
- 【MySQL(1)| B-tree和B+tree】MySql
- B2BecNews:2019年B2B製造商300調查
- 宋小菜如何切入生鮮 B2B 市場(B2B 技術共享第二篇)
- 非 A 或 B 等價於非 A 且非 B
- 多路查詢樹:B-tree/b+tree
- 平衡二叉樹,B樹,B+樹二叉樹
- B - Make Numbers Gym - 102835B(表示式,暴力)
- 二叉樹、B樹以及B+樹二叉樹
- 筆記:從Aurora 8b/10b 到Aurora 64b/66b (三):自定義PHY層收發筆記
- 電子元器件B2B商城系統:授信大額支付,精細化B2B平臺管理
- Intel低調發布酷睿B系列 含i7-8700B、i5-8500B/8400B三款Intel
- 生鮮 B2B 如何搭建高效的技術團隊(B2B 技術共享第四篇)
- AMD平臺B450與B350主機板對比 B450和B350哪個好?
- B2BecNews:2019年美國B2B電子商務報告
- B 樹和 B+樹的區別, 為什麼 MySQL 要使用 B+樹MySql
- B站下載
- B. 酒杯
- B - Minimum Sum
- B-tree
- B+tree
- 啥b事
- B - Ticket Counter
- 1312b
- As Easy As A+B
- 數商雲:化工B2B電子商務之化工行業B2B網站痛點有哪些行業網站