As Easy As A+B
Problem DescriptionThese days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights. InputInput contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line. OutputFor each case, print the sorting result, and one line one case. Sample Input
Sample Output
|
題意:
描述:
這些天,我在想一個問題,我怎樣才能讓一個問題變得像A+B一樣容易?做這樣的事是相當困難的。當然,我是在清醒了好幾個晚上之後才拿到的。
給你一些整數,你的任務是排序這些數字(升序)。
你應該知道現在的問題有多容易!
祝你好運!
輸入:
輸入包含多個測試用例。輸入的第一行是單整數t,是測試用例的數目。下面是一些測試用例。每個測試用例都包含一個整數n(1<=n<=1000,要排序的整數數目),然後n個整數在同一行跟隨。
保證所有的整數都在32-int的範圍內。
輸出:
對每個情況,列印排序結果,並一行一個情況。
AC碼:
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1005;
int a[maxn];
int main()
{
int t,n;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
sort(a,a+n);
for(int i=0;i<n;i++)
{
if(i!=n-1)
printf("%d ",a[i]);
else
printf("%d\n",a[i]);
}
}
return 0;
}
相關文章
- HDU 1040 As Easy As A+B(堆排序)排序
- A+B
- A+B問題
- hdu 1720 A+B Coming
- [#181024][PAT Practice] A+B FormatORM
- [Algorithm] 1. A+B ProblemGo
- 1016. 部分A+B (15)
- ●Joyoi Easy
- Python入門:A+B問題Python
- [PAT B] 1011 A+B 和 C
- PAT:1001 A+B Format (20分)ORM
- A+B 演算法問題演算法
- 2020/12/27 G小明A+B
- 1016 部分A+B (15 分)JavaJava
- PAT-B 1016 部分A+B
- 【BUUCTF】Easy JavaJava
- 【BUUCTF】easy calc
- Leetcode(easy heap)LeetCode
- Easy-Admin
- 字串魔法(easy)字串
- LeetCode-EasyLeetCode
- PAT-B 1093 字串A+B 【集合】字串
- PAT-B 1011 A+B 和 C
- Fractal pg walkthrough Easy
- Hub PG walkthrough Easy
- [RoarCTF 2019]Easy Calc
- Catch the Mole(Easy Version)
- type challenge(easy 部分)
- Prefix Flip (Easy Version)
- vue-easy-rendererVue
- j-easy/easy-rules: Java簡單的規則引擎Java
- 1016 部分A+B (15分)【java題解】Java
- PAT答案(D進位制的A+B)
- 攻防世界-Easy_Crypto
- [RoarCTF 2019]Easy Java 1Java
- 攻防世界-Easy_ECC
- 攻防世界-easy_RSA
- ES-Client-easy esclient