As Easy As A+B

韓小妹發表於2018-08-09

Problem Description

These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!

Input

Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.

Output

For each case, print the sorting result, and one line one case.

Sample Input

2

3 2 1 3

9 1 4 7 2 5 8 3 6 9

Sample Output

1 2 3

1 2 3 4 5 6 7 8 9

題意:

描述:

這些天,我在想一個問題,我怎樣才能讓一個問題變得像A+B一樣容易?做這樣的事是相當困難的。當然,我是在清醒了好幾個晚上之後才拿到的。

給你一些整數,你的任務是排序這些數字(升序)。
你應該知道現在的問題有多容易!
祝你好運!

輸入:

輸入包含多個測試用例。輸入的第一行是單整數t,是測試用例的數目。下面是一些測試用例。每個測試用例都包含一個整數n(1<=n<=1000,要排序的整數數目),然後n個整數在同一行跟隨。
保證所有的整數都在32-int的範圍內。

輸出:

對每個情況,列印排序結果,並一行一個情況。

AC碼:

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1005;
int a[maxn];
int main()
{
	int t,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		scanf("%d",&a[i]);
		sort(a,a+n);
		for(int i=0;i<n;i++)
		{
			if(i!=n-1)
			printf("%d ",a[i]);
			else
			printf("%d\n",a[i]);
		}
	}
	return 0;
}