POJ1273 Drainage Ditches【網路流 最大流】

Enjoy_process發表於2018-09-04

Drainage Ditches

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 85397   Accepted: 33232

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

Source

USACO 93

問題連結:POJ1273 Drainage Ditches

題解:最大流的模板題

AC的C++程式碼:

#include<iostream>
#include<cstring>
#include<queue>

using namespace std;
const int N=205;
const int INF=0x3f3f3f3f;
int g[N][N];
int pre[N];//路徑上每個結點的前驅結點
bool vis[N];
int n,m;//m是頂點數目,頂點編號從1開始 1是源,m是匯,n是邊數

int EdmondsKarp()
{
	int i,v;
	queue<int>q;
	memset(pre,-1,sizeof(-1));
	memset(vis,0,sizeof(vis));
	pre[1]=0;
	vis[1]=1;
	q.push(1);
	bool flag=false;//標記bfs是否尋找到一條源到匯的可行路徑
	while(!q.empty()){
		v=q.front();
		q.pop();
		for(int i=1;i<=m;i++)
		  if(g[v][i]>0&&vis[i]==0){//必須是依然有容量的邊,才可以走 
		      pre[i]=v;
		      vis[i]=1;
		      if(i==m){
		      	flag=true;
		      	break;
			  }
			  else
			    q.push(i);
		  } 
	}
	if(!flag)//找不到就退出 
	  return 0;
	int ans=INF;
	v=m;
	//尋找源到匯路徑上容量最小的邊,其容量就是此次增加的總流量
	while(pre[v]){
		ans=min(ans,g[pre[v]][v]);
		v=pre[v];
	} 
	//沿此路徑新增反向邊,同時修改路徑上每條邊的容量
	v=m;
	while(pre[v]){
		g[pre[v]][v]-=ans;
		g[v][pre[v]]+=ans;
		v=pre[v];
	}
	return ans; 
}

int main()
{
	while(cin>>n>>m){//m是頂點數目,頂點編號從1開始
		int s,e,c;
		memset(g,0,sizeof(g));
		for(int i=1;i<=n;i++){
			cin>>s>>e>>c;
			g[s][e]+=c;//兩點之間可能有多條邊 
		} 
		int ans=0,tmp;
		while(tmp=EdmondsKarp())
		  ans+=tmp;
		cout<<ans<<endl;
	}
	return 0;
}

 

相關文章