2014西安網路賽1008||hdu5014 二進位制

life4711發表於2014-09-16

http://acm.hdu.edu.cn/showproblem.php?pid=5014

Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● ai ∈ [0,n] 
● ai ≠ aj( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a0 ⊕ b0) + (a1 ⊕ b1) +···+ (an ⊕ bn)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line contains an integer n(1 ≤ n ≤ 105), The second line contains a0,a1,a2,...,an.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b0,b1,b2,...,bn. There is exactly one space between bi and bi+1(0 ≤ i ≤ n - 1). Don’t ouput any spaces after bn.
 

Sample Input
4 2 0 1 4 3
 

Sample Output
20 1 0 2 3 4
 

解題思路:我們知道一個數有n個二進位制位,我們就把它異或成(1<< n)-1,就最大了,因此我們給每一個數從大到小用(1<< n)-1做異或就能得到與之對應的數,注意一定不能從小到大做。

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;

typedef __int64 LL;
const int N=100055;

int a[N],b[N],vis[N];
int n;

int get(int x)
{
    int num=0;
    while(x)
    {
        x>>=1;
        num++;
    }
    return num;
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<=n;i++)
            scanf("%d",&a[i]);
        memset(vis,-1,sizeof(vis));
        for(int i=n;i>=0;i--)
        {
            if(vis[i]!=-1)
                continue;
            int x=get(i);
            int tmp=((1<<x)-1)^i;
            b[i]=tmp;
            b[tmp]=i;
            //printf("%d\n",b[i]);
            vis[tmp]=1;
            vis[i]=1;
        }
        LL sum=0;
        for(int i=0;i<=n;i++)
            sum+=(LL)(i^b[i]);
        printf("%I64d\n",sum);
        for(int i=0;i<=n;i++)
            printf(i!=n?"%d ":"%d\n",b[a[i]]);
    }
    return 0;
}


相關文章