UVA 536 二叉樹的遍歷

life4711發表於2014-07-25

http://vjudge.net/contest/view.action?cid=50788#problem/B

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

                                    D
                                   / \
                                  /   \
                                 B     E
                                / \     \
                               /   \     \ 
                              A     C     G
                                         /
                                        /
                                       F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree).

For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).


Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!

Input Specification 

The input file will contain one or more test cases. Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.

Output Specification 

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input 

DBACEGF ABCDEFG
BCAD CBAD

Sample Output 

ACBFGED
CDAB
題目大意:給出一個二叉樹的前序遍歷和中序遍求出它的後序遍歷的結果

解題思路: 

               對於前序遍歷而言總是先遍歷根節點接著是左子樹,右子樹。對於中序遍歷而言就是先遍歷左子樹,根節點和右子樹,因此對遍歷順序為左子樹,右子樹根節點的後序遍歷來說,最後出現的一定是根節點,因此我們只需把根節點和其右左子樹的根節點依次入棧,最後將棧裡的元素全部退出就可以了

#include <stdio.h>
#include <string.h>
#define M 30
char stack[M];
int top;
void dfs(char *pre,char *mid)
{
    char ps1[M],ps2[M],*qs1,*qs2;
    int index;
    if(strlen(pre))
    {
        stack[top++]=pre[0];
        index=strchr(mid,pre[0])-mid;
        qs1=mid;
        qs2=mid+index+1;
        mid[index]=0;
        strncpy(ps1,pre+1,index);
        ps1[index]=0;
        strcpy(ps2,pre+1+index);
        dfs(ps2,qs2);
        dfs(ps1,qs1);
    }
    return ;
}
int main()
{
    char pre[M],mid[M];
    while(~scanf("%s%s",pre,mid))
    {
         top=0;
         dfs(pre,mid);
         while(top>0)
             printf("%c",stack[--top]);
        puts("");
    }
    return 0;
}


相關文章