hdu 4122Alice's mooncake shop(單調佇列)

果7發表於2013-11-02

Alice's mooncake shop

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2531    Accepted Submission(s): 600


Problem Description
The Mid-Autumn Festival, also known as the Moon Festival or Zhongqiu Festival is a popular harvest festival celebrated by Chinese people, dating back over 3,000 years to moon worship in China's Shang Dynasty. The Zhongqiu Festival is held on the 15th day of the eighth month in the Chinese calendar, which is in September or early October in the Gregorian calendar. It is a date that parallels the autumnal equinox of the solar calendar, when the moon is at its fullest and roundest. 

The traditional food of this festival is the mooncake. Chinese family members and friends will gather to admire the bright mid-autumn harvest moon, and eat mooncakes under the moon together. In Chinese, “round”(圓) also means something like “faultless” or “reuion”, so the roundest moon, and the round mooncakes make the Zhongqiu Festival a day of family reunion.

Alice has opened up a 24-hour mooncake shop. She always gets a lot of orders. Only when the time is K o’clock sharp( K = 0,1,2 …. 23) she can make mooncakes, and We assume that making cakes takes no time. Due to the fluctuation of the price of the ingredients, the cost of a mooncake varies from hour to hour. She can make mooncakes when the order comes,or she can make mooncakes earlier than needed and store them in a fridge. The cost to store a mooncake for an hour is S and the storage life of a mooncake is T hours. She now asks you for help to work out a plan to minimize the cost to fulfill the orders.
 

Input
The input contains no more than 10 test cases. 
For each test case:
The first line includes two integers N and M. N is the total number of orders. M is the number of hours the shop opens. 
The next N lines describe all the orders. Each line is in the following format:

month date year H R

It means that on a certain date, a customer orders R mooncakes at H o’clock. “month” is in the format of abbreviation, so it could be "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov" or "Dec". H and R are all integers. 
All the orders are sorted by the time in increasing order. 
The next line contains T and S meaning that the storage life of a mooncake is T hours and the cost to store a mooncake for an hour is S.
Finally, M lines follow. Among those M lines, the ith line( i starts from 1) contains a integer indicating the cost to make a mooncake during the ith hour . The cost is no more than 10000. Jan 1st 2000 0 o'clock belongs to the 1st hour, Jan 1st 2000 1 o'clock belongs to the 2nd hour, …… and so on.

(0<N <= 2500; 0 < M,T <=100000; 0<=S <= 200; R<=10000 ; 0<=H<24)

The input ends with N = 0 and M = 0.
 

Output
You should output one line for each test case: the minimum cost. 
 

Sample Input
1 10 Jan 1 2000 9 10 5 2 20 20 20 10 10 8 7 9 5 10 0 0
 

Sample Output
70
Hint
“Jan 1 2000 9 10” means in Jan 1st 2000 at 9 o'clock , there's a consumer ordering 10 mooncakes. Maybe you should use 64-bit signed integers. The answer will fit into a 64-bit signed integer.
 

Source
 


題目大意:訂單來之前可以先把月餅做了,不過月餅儲存一個小時需要money S,而且怎麼儲存都不能將時間超過T。當時讀這個題目讀得傷心欲絕。。。而且象棋也是那個也是傷。最後將題目簡化成了一個區間求最小值,單調佇列或者線段樹。。

題目地址:Alice's mooncake shop


AC程式碼:
#include<ioStream>
#include<cStdio>
#include<String>
#include<cString>
#include<map>
using namespace std;
int n,m;
int a[100005];

map<string,int> mon;
void preSolve()
{
    mon["Jan"]=1;
    mon["Feb"]=2;
    mon["Mar"]=3;
    mon["Apr"]=4;
    mon["May"]=5;
    mon["Jun"]=6;
    mon["Jul"]=7;
    mon["Aug"]=8;
    mon["Sep"]=9;
    mon["Oct"]=10;
    mon["Nov"]=11;
    mon["Dec"]=12;
}

int dd[2][13]={{0,31,28,31,30,31,30,31,31,30,31,30,31},{0,31,29,31,30,31,30,31,31,30,31,30,31}};

struct node
{
    int tim;
    int num;
}order[2505],que[100005];

int iSrunyear(int y)
{
    if(y%400==0||(y%4==0&&y%100!=0)) return 1;
    return 0;
}

int caltim(int m,int d,int y,int h)
{
    int i;
    for(i=2000;i<y;i++)
    {
        h+=365*24;
        if(iSrunyear(i)) h+=24;
    }

    int tt=iSrunyear(y);
    for(i=1;i<m;i++)   //月份
        h+=dd[tt][i]*24;
    for(i=1;i<d;i++)   //加上天數
        h+=24;
    return h;
}

int main()
{
    preSolve();
    int i,day,year,hour,T,S;
    char Str[6];
    while(cin>>n>>m&&(n||m))
    {
        for(i=0;i<n;i++)
        {
            scanf("%s%d%d%d%d",Str,&day,&year,&hour,&order[i].num);
            order[i].tim=caltim(mon[Str],day,year,hour);
            cout<<order[i].tim<<" "<<order[i].num<<endl;
        }
        cin>>T>>S;

        int top=0,tail=0,p=0;
        __int64 Sum=0;
        int he;
        for(int i=0;i<m;i++)     //tim存下標,num存值
        {
            scanf("%d",&he);
            while(top<tail && que[tail-1].num+(i-que[tail-1].tim)*S>=he) tail--;
            que[tail].num=he,que[tail++].tim=i;
            while(i == order[p].tim)  //重點
            {
                while(que[top].tim+T<i) top++;
                Sum+=(que[top].num+(i-que[top].tim)*S)*order[p++].num;
            }
        }
        printf("%I64d\n",Sum);
    }
    return 0;
}

/*
1 10
Jan 1 2000 9 10
5 2
20
20
20
10
10
8
7
9
5
10
*/


相關文章