FZU 1894 單調佇列入門

_rabbit發表於2014-05-12
Problem 1894 志願者選拔

Accept: 1296    Submit: 4081
Time Limit: 1500 mSec    Memory Limit : 32768 KB

Problem Description

世博會馬上就要開幕了,福州大學組織了一次志願者選拔活動。
參加志願者選拔的同學們排隊接受面試官們的面試。參加面試的同學們按照先來先面試並且先結束的原則接受面試官們的考查。
面試中每個人的人品是主要考查物件之一。(提高人品的方法有扶老奶奶過街,不闖紅燈等)
作為主面試官的John想知道當前正在接受面試的同學隊伍中人品值最高的是多少。於是他請你幫忙編寫一個程式來計算。

Input

輸入資料第一行為一整數T,表示有T組輸入資料。每組資料第一行為”START”,表示面試開始
接下來的資料中有三種情況:
  輸入 含義
1 C NAME RP_VALUE 名字為NAME的人品值為RP_VALUE的同學加入面試隊伍。(名字長度不大於5,0 <= RP_VALUE <= 1,000,000,000)
2 G 排在面試隊伍最前面的同學面試結束離開考場。
3 Q 主面試官John想知道當前正在接受面試的隊伍中人品最高的值是多少。
最後一行為”END”,表示所有的面試結束,面試的同學們可以依次離開了。
所有參加面試的同學總人數不超過1,000,000

Output

對於每個詢問Q,輸出當前正在接受面試的隊伍中人品最高的值,如果當前沒有人正在接受面試則輸出-1。

Sample Input

2STARTC Tiny 1000000000C Lina 0QGQENDSTARTQC ccQ 200C cxw 100QGQC wzc 500QEND

Sample Output

10000000000-1200100500

Hint

資料較大建議使用scanf,printf不推薦使用STL

Source

福州大學第七屆程式設計競賽


單調佇列裸題,用一個雙端佇列維護一個遞減的序列,然後掃一遍就行,由於資料規模超大,nlogn的方法會tle,單調佇列也只能飄過。

程式碼:

/* ***********************************************
Author :_rabbit
Created Time :2014/5/12 22:14:46
File Name :20.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define pi acos(-1.0)
typedef long long ll;
int que[1001000],a[1001000];
int main()
{
     //freopen("data.in","r",stdin);
     //freopen("data.out","w",stdout);
     int T,head,end,front,tail;
	 char str[100],ss[223];
	 scanf("%d",&T);
	 while(T--){
		 front=tail=head=end=0;
		 scanf("%s",str);
		 while(~scanf("%s",str)&&str[0]!='E'){
			 if(str[0]=='C'){
			 	scanf("%s",ss);
			 	scanf("%d",&a[end++]);
			 	while(front<tail&&a[que[tail-1]]<a[end-1])tail--;
			 	que[tail++]=end-1;
			 }
			 else if(str[0]=='G')head++;
			 else {
			 	 if(head<end){
					 while(que[front]<head)front++;
					 printf("%d\n",a[que[front]]);
			 	 }
				 else puts("-1");
		 	 }
		 }
	 }
     return 0;
}


相關文章