hdu4374單調佇列+dp

life4711發表於2015-02-09

http://acm.hdu.edu.cn/showproblem.php?pid=4374

Problem Description
Now there is a game called the new man down 100th floor. The rules of this game is:
  1.  At first you are at the 1st floor. And the floor moves up. Of course you can choose which part you will stay in the first time.
  2.  Every floor is divided into M parts. You can only walk in a direction (left or right). And you can jump to the next floor in any part, however if you are now in part “y”, you can only jump to part “y” in the next floor! (1<=y<=M)
  3.  There are jags on the ceils, so you can only move at most T parts each floor.
  4.  Each part has a score. And the score is the sum of the parts’ score sum you passed by.
Now we want to know after you get the 100th floor, what’s the highest score you can get.
 

Input
The first line of each case has four integer N, M, X, T(1<=N<=100, 1<=M<=10000, 1<=X, T<=M). N indicates the number of layers; M indicates the number of parts. At first you are in the X-th part. You can move at most T parts in every floor in only one direction.
Followed N lines, each line has M integers indicating the score. (-500<=score<=500)
 

Output
Output the highest score you can get.
 

Sample Input
3 3 2 1 7 8 1 4 5 6 1 2 3
 

Sample Output
29

/**
hdu 4374   單調佇列+dp
題目大意:一個n層的樓,每層樓有m個格子,每個格子有一定的價值。在每一層樓只能向一個方向走最多走t步,
          開始在頂層的x位置,問到底層的路線上能得到的價值最大。
解題思路:從下往上走,每個狀態dp[i][j]為從i層j格子到底層所能得到的最大價值。
          用sum[i][j]表示第i層前j格子的和。
          從左邊到j位置的狀態轉移方程 dp[i][j]=max(dp[i+1][k]+sum[i][j]-sum[i][k-1]);(k+t<=j)。
          上式即為:dp[i][j]=max(dp[i+1][k]-sum[i][k-1])+sum[i][j+1];
          由於max裡面包含的項都已知切與j無關。故可以用單調佇列,維護單調遞增即可。
          其右邊的狀態轉移方程為dp[i][j]=max(dp[i+1][k]+sum[i][k])-sum[i][j-1];(k-t>=j)
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;

int n,m,x,t,a[105][10005],dp[105][10005],sum[105][10005];
int q[10005],front,rear,ans_l[10005],ans_r[10005];

int main()
{
    while(~scanf("%d%d%d%d",&n,&m,&x,&t))
    {
        memset(dp,0,sizeof(dp));
        memset(sum,0,sizeof(sum));
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
            {
                scanf("%d",&a[i][j]);
                sum[i][j]=sum[i][j-1]+a[i][j];
            }
        }
        for(int i=n; i>=1; i--)
        {
            front=0;
            rear=0;
            q[rear++]=1;
            ans_l[1]=1;
            for(int j=2; j<=m; j++)
            {
                while(front<rear&&dp[i+1][q[rear-1]]-sum[i][q[rear-1]-1]<=dp[i+1][j]-sum[i][j-1])
                {
                    rear--;
                }
                q[rear++]=j;
                if(q[front]+t<j)
                    front++;
                ans_l[j]=q[front];
            }
            front=0;
            rear=0;
            q[rear++]=m;
            ans_r[m]=m;
            for(int j=m-1; j>=1; j--)
            {
                while(front<rear&&dp[i+1][q[rear-1]]+sum[i][q[rear-1]]<=dp[i+1][j]+sum[i][j])
                {
                    rear--;
                }
                q[rear++]=j;
                if(q[front]-t>j)
                    front++;
                ans_r[j]=q[front];
            }
            int t1,t2;
            for(int j=1; j<=m; j++)
            {
                t1=dp[i+1][ans_l[j]]+sum[i][j]-sum[i][ans_l[j]-1];
                t2=dp[i+1][ans_r[j]]+sum[i][ans_r[j]]-sum[i][j-1];
                dp[i][j]=max(t1,t2);
            }
        }
        printf("%d\n",dp[1][x]);
    }
    return 0;
}


相關文章