hdu3415 單調佇列求區間最大和

life4711發表於2014-11-11

http://acm.hdu.edu.cn/showproblem.php?pid=3415

Problem Description
Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. 
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.
 

Sample Input
4 6 3 6 -1 2 -6 5 -5 6 4 6 -1 2 -6 5 -5 6 3 -1 2 -6 5 -5 6 6 6 -1 -1 -1 -1 -1 -1
 

Sample Output
7 1 3 7 1 3 7 6 2 -1 1 1
 

/**
hdu3415 單調佇列
題目大意:給出一個有N個數字(N<=10^5)的環狀序列,讓你求一個和最大的連續子序列。這個連續子序列的長度小於等於K。
分析:因為序列是環狀的,所以可以在序列後面複製前k-1個數字。如果用s[i]來表示複製過後的序列的前i個數的和,那麼任意一個子序列[i..j]的和就等於s[j]-s[i-1]。
對於每一個j,用s[j]減去最小的一個s[i](i>=j-k)就可以得到以j為終點長度不大於k的和最大的序列了。將原問題轉化為這樣一個問題後,就可以用單調佇列解決了。
單調佇列即保持佇列中的元素單調遞增(或遞減)的這樣一個佇列,可以從兩頭刪除,只能從隊尾插入。單調佇列的具體作用在於,由於保持佇列中的元素滿足單調性,
對於上述問題中的每個j,可以用O(1)的時間找到對應的s[i]。(保持佇列中的元素單調遞增的話,隊首元素便是所要的元素了)。
維護方法:對於每個j,我們插入s[j-1]的下標,插入時從隊尾插入。為了保證佇列的單調性,我們從隊尾開始刪除元素,直到隊尾元素對應的值比當前需要插入的s[j-1]小,
就將當前元素下標插入到隊尾。之所以可以將之前的佇列尾部元素全部刪除,是因為它們已經不可能成為最優的元素了,因為當前要插入的元素位置比它們靠前,
對應的值比它們小。我們要找的,是滿足(i>=j-k)的i中最小的s[i]。在插入元素後,從隊首開始,將不符合限制條件(i<j-k)的元素全部刪除,此時佇列一定不為空。(因為剛剛插入了一個一定符合條件的元素)。
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;

const int inf=1e9;
const int N=200002;
int n,k,T,a[N],q[N];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&k);
        a[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            a[i]+=a[i-1];
        }
        for(int i=n+1;i<n+k;i++)
            a[i]=a[n]+a[i-n];
        int m=n+k-1;
        int head=0,tail=0;
        int maxx=-inf;
        int l,r;
        for(int i=1;i<=m;i++)
        {
            while(head<tail&&a[i-1]<a[q[tail-1]])
                tail--;
            q[tail++]=i-1;
            while(head<tail&&i-q[head]>k)
                  head++;
            if(maxx<a[i]-a[q[head]])
            {
                maxx=a[i]-a[q[head]];
                l=q[head]+1;
                r=i>n?i%n:i;
            }
        }
        printf("%d %d %d\n",maxx,l,r);
    }
    return 0;
}


相關文章