hdu 4122 單調佇列
http://acm.hdu.edu.cn/showproblem.php?pid=4122
Problem Description
The Mid-Autumn Festival, also known as the Moon Festival or Zhongqiu Festival is a popular harvest festival celebrated by Chinese people, dating back over 3,000 years to moon worship in China's Shang Dynasty. The Zhongqiu Festival is held on the 15th day of
the eighth month in the Chinese calendar, which is in September or early October in the Gregorian calendar. It is a date that parallels the autumnal equinox of the solar calendar, when the moon is at its fullest and roundest.
The traditional food of this festival is the mooncake. Chinese family members and friends will gather to admire the bright mid-autumn harvest moon, and eat mooncakes under the moon together. In Chinese, “round”(圓) also means something like “faultless” or “reuion”, so the roundest moon, and the round mooncakes make the Zhongqiu Festival a day of family reunion.
Alice has opened up a 24-hour mooncake shop. She always gets a lot of orders. Only when the time is K o’clock sharp( K = 0,1,2 …. 23) she can make mooncakes, and We assume that making cakes takes no time. Due to the fluctuation of the price of the ingredients, the cost of a mooncake varies from hour to hour. She can make mooncakes when the order comes,or she can make mooncakes earlier than needed and store them in a fridge. The cost to store a mooncake for an hour is S and the storage life of a mooncake is T hours. She now asks you for help to work out a plan to minimize the cost to fulfill the orders.
The traditional food of this festival is the mooncake. Chinese family members and friends will gather to admire the bright mid-autumn harvest moon, and eat mooncakes under the moon together. In Chinese, “round”(圓) also means something like “faultless” or “reuion”, so the roundest moon, and the round mooncakes make the Zhongqiu Festival a day of family reunion.
Alice has opened up a 24-hour mooncake shop. She always gets a lot of orders. Only when the time is K o’clock sharp( K = 0,1,2 …. 23) she can make mooncakes, and We assume that making cakes takes no time. Due to the fluctuation of the price of the ingredients, the cost of a mooncake varies from hour to hour. She can make mooncakes when the order comes,or she can make mooncakes earlier than needed and store them in a fridge. The cost to store a mooncake for an hour is S and the storage life of a mooncake is T hours. She now asks you for help to work out a plan to minimize the cost to fulfill the orders.
Input
The input contains no more than 10 test cases.
For each test case:
The first line includes two integers N and M. N is the total number of orders. M is the number of hours the shop opens.
The next N lines describe all the orders. Each line is in the following format:
month date year H R
It means that on a certain date, a customer orders R mooncakes at H o’clock. “month” is in the format of abbreviation, so it could be "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov" or "Dec". H and R are all integers.
All the orders are sorted by the time in increasing order.
The next line contains T and S meaning that the storage life of a mooncake is T hours and the cost to store a mooncake for an hour is S.
Finally, M lines follow. Among those M lines, the ith line( i starts from 1) contains a integer indicating the cost to make a mooncake during the ith hour . The cost is no more than 10000. Jan 1st 2000 0 o'clock belongs to the 1st hour, Jan 1st 2000 1 o'clock belongs to the 2nd hour, …… and so on.
(0<N <= 2500; 0 < M,T <=100000; 0<=S <= 200; R<=10000 ; 0<=H<24)
The input ends with N = 0 and M = 0.
For each test case:
The first line includes two integers N and M. N is the total number of orders. M is the number of hours the shop opens.
The next N lines describe all the orders. Each line is in the following format:
month date year H R
It means that on a certain date, a customer orders R mooncakes at H o’clock. “month” is in the format of abbreviation, so it could be "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov" or "Dec". H and R are all integers.
All the orders are sorted by the time in increasing order.
The next line contains T and S meaning that the storage life of a mooncake is T hours and the cost to store a mooncake for an hour is S.
Finally, M lines follow. Among those M lines, the ith line( i starts from 1) contains a integer indicating the cost to make a mooncake during the ith hour . The cost is no more than 10000. Jan 1st 2000 0 o'clock belongs to the 1st hour, Jan 1st 2000 1 o'clock belongs to the 2nd hour, …… and so on.
(0<N <= 2500; 0 < M,T <=100000; 0<=S <= 200; R<=10000 ; 0<=H<24)
The input ends with N = 0 and M = 0.
Output
You should output one line for each test case: the minimum cost.
Sample Input
1 10
Jan 1 2000 9 10
5 2
20
20
20
10
10
8
7
9
5
10
0 0
Sample Output
70
Hint
“Jan 1 2000 9 10” means in Jan 1st 2000 at 9 o'clock , there's a consumer ordering 10 mooncakes.
Maybe you should use 64-bit signed integers. The answer will fit into a 64-bit signed integer./**
hdu 4122 單調佇列
題目大意:給定n個時刻,在每一個時刻都要生產ai個月餅。給出m個可以生產的時刻,每個時刻單個生產費用為bi,單個月餅可儲存T時間,單位時間費用為S
問如何安排生產花費最少
解題思路:用單調佇列維護一個點之前所有點的最小花費(為生產費+儲存費)
特別注意:n個時刻可能有重複的
*/
#include <string.h>
#include <algorithm>
#include <iostream>
#include <stdio.h>
#include <map>
using namespace std;
typedef long long LL;
map<string,int>mp;
int n,m,time[3050],sum[15],S,T,cost[100050],q[100050];
LL num[3000];
void init()
{
mp["Jan"]=1,mp["Feb"]=2,mp["Mar"]=3,mp["Apr"]=4,mp["May"]=5,mp["Jun"]=6,mp["Jul"]=7,mp["Aug"]=8;
mp["Sep"]=9,mp["Oct"]=10,mp["Nov"]=11,mp["Dec"]=12;
sum[0]=0,sum[1]=31,sum[2]=sum[1]+28,sum[3]=sum[2]+31,sum[4]=sum[3]+30,sum[5]=sum[4]+31,sum[6]=sum[5]+30;
sum[7]=sum[6]+31,sum[8]=sum[7]+31,sum[9]=sum[8]+30,sum[10]=sum[9]+31,sum[11]=sum[10]+30;
}
int get(int y,int m,int d,int t)
{
int ans=0;
for(int i=2000; i<y; i++)
{
if((i%4==0&&i%100!=0)||i%400==0)
ans+=366;
else
ans+=365;
}
if((y%4==0&&y%100!=0)||y%400==0)
{
ans+=sum[m-1];
if(m-1>=2)ans++;
}
else
{
ans+=sum[m-1];
}
ans+=(d-1);
return ans*24+t;
}
int main()
{
init();
while(~scanf("%d%d",&n,&m))
{
if(n==0&&m==0)break;
for(int i=0; i<n; i++)
{
int year,day,t;
char mon[10];
scanf("%s%d%d%d%I64d",mon,&day,&year,&t,&num[i]);
time[i]=get(year,mp[mon],day,t);
//printf("->%d\n",time[i]);
}
scanf("%d%d",&T,&S);
int tail=0,head=0,k=0;
LL cnt=0;
for(int i=0; i<m; i++)
{
scanf("%d",&cost[i]);
while(head<tail&&cost[q[tail-1]]+S*(i-q[tail-1])>=cost[i])tail--;
q[tail++]=i;
while(i==time[k])
{
while(head+1<tail&&(i-q[head]>T))head++;
//printf("%d==>>%d\n",i,q[head]);
cnt+=num[k]*(cost[q[head]]+S*(i-q[head]));
k++;
}
}
printf("%I64d\n",cnt);
}
return 0;
}
/**
2 10
Jan 1 2000 2 10
Jan 1 2000 9 10
5 2
20
20
20
10
10
8
7
9
5
10
0 0
*/
相關文章
- 單調佇列佇列
- 單調棧/單調佇列佇列
- 單調佇列雙端佇列佇列
- 單調棧 和 單調佇列佇列
- 單調棧和單調佇列佇列
- 單調佇列最佳化 DP佇列
- 佇列-單端佇列佇列
- noi.ac #289. 電梯(單調佇列)佇列
- 多重揹包問題的單調佇列優化佇列優化
- BZOJ1044: [HAOI2008]木棍分割(dp 單調佇列)佇列
- [學習筆記] 單調佇列最佳化DP - DP筆記佇列
- RabbitMQ-簡單佇列MQ佇列
- 單向鏈式佇列佇列
- 棧,佇列,優先順序佇列簡單介面使用佇列
- python中佇列簡單使用Python佇列
- 佇列_單向連結串列佇列
- laravel 佇列的簡單使用Laravel佇列
- 實現簡單延遲佇列和分散式延遲佇列佇列分散式
- 佇列、阻塞佇列佇列
- 聯賽模擬測試18 A. 施工 單調佇列(棧)優化DP佇列優化
- kuangbin 專題二十三:二分 尺取 單調棧佇列 String佇列
- 單調佇列優化dp(五)——#10179. 「一本通 5.5 例 5」Banknotes佇列優化
- 佇列 和 迴圈佇列佇列
- 【佇列】【懶排序】佇列Q佇列排序
- 1284 海港 普及組 NOIP2016 佇列基礎 簡單列舉 簡單模擬 優先佇列(priority_queue)佇列
- 自定義單連結串列佇列的基本介面函式(非迴圈佇列)佇列函式
- 陣列模擬佇列 以及佇列的複用(環形佇列)陣列佇列
- “簡單”的訊息佇列與kafka佇列Kafka
- redis訊息佇列簡單應用Redis佇列
- 簡單易用的任務佇列-beanstalkd佇列Bean
- 佇列 手算到機算 入門 佇列 迴圈佇列佇列
- 圖解--佇列、併發佇列圖解佇列
- 洛谷題單指南-常見最佳化技巧-P1886 滑動視窗 /【模板】單調佇列佇列
- 佇列佇列
- HDU 1556【區間更新+單點查詢 樹狀陣列】陣列
- RabbitMQ 訊息佇列之佇列模型MQ佇列模型
- Kafka 延時佇列&重試佇列Kafka佇列
- P6087 [JSOI2015]送禮物 01分數規劃+單調佇列+ST表JS佇列
- netcore下RabbitMQ佇列、死信佇列、延時佇列及小應用NetCoreMQ佇列