HDU3530 單調佇列的應用

life4711發表於2014-11-12

http://acm.hdu.edu.cn/showproblem.php?pid=3530

Problem Description
There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.
 

Input
There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.
 

Output
For each test case, print the length of the subsequence on a single line.
 

Sample Input
5 0 0 1 1 1 1 1 5 0 3 1 2 3 4 5
 

Sample Output
5 4
/**
HDU 3530  單調佇列的應用
題意:
     給定一段序列,求出最長的一段子序列使得該子序列中最大最小隻差x滿足m<=x<=k。
解題思路:
     建立兩個單調佇列分別遞增和遞減維護(頭尾刪除,只有尾可插入)
     Max - Min 為兩個佇列的隊首之差while(Max-Min>K) 看哪個的隊首元素比較前就移動誰的
     最後求長度時,需要先記錄上一次的被淘汰的最值位置last ,這樣[last+1,i]即為滿足條件的連續子序列了
i - last
*/
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
const int N=100005;
int q_max[N],q_min[N];//遞增,遞減
int a[N],n,m,k;
int main()
{
    while(~scanf("%d%d%d",&n,&m,&k))
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        int head_min=0,head_max=0,tail_min=0,tail_max=0;
        int left1=0,left2=0;
        int maxx=0;
        for(int i=1;i<=n;i++)
        {
            while(head_min<tail_min&&a[q_min[tail_min-1]]<=a[i])
                tail_min--;
            while(head_max<tail_max&&a[q_max[tail_max-1]]>=a[i])
                tail_max--;
            q_max[tail_max++]=q_min[tail_min++]=i;
           /* printf("***%d 遞減、遞增***\n",i);
            for(int j=head_min;j<tail_min;j++)
                   printf("%d ",a[q_min[j]]);
            printf("\n");
            for(int j=head_max;j<tail_max;j++)
                   printf("%d ",a[q_max[j]]);
            printf("\n");*/
            while(a[q_min[head_min]]-a[q_max[head_max]]>k)
            {
                if(q_min[head_min]<q_max[head_max])
                      left1=q_min[head_min++];
                else
                      left2=q_max[head_max++];
            }
            if(a[q_min[head_min]]-a[q_max[head_max]]>=m)
                  maxx=max(maxx,i-max(left1,left2));
        }
        printf("%d\n",maxx);
    }
    return 0;
}
/*
5 2 3
1 -1 2 -6 5
5 1 3
1 2 3 4 5
6 0 0
-1 0 2 1 125 -5
*/


相關文章