POJ 1579-Function Run Fun(記憶化搜尋-遞迴)

kewlgrl發表於2017-04-28
Function Run Fun
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 18930   Accepted: 9612

Description

We all love recursion! Don't we? 

Consider a three-parameter recursive function w(a, b, c): 

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 


if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 
w(20, 20, 20) 

if a < b and b < c, then w(a, b, c) returns: 
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 

otherwise it returns: 
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

Source


題目意思:

給出a,b,c,按以下遞迴方式計算w(a, b, c):
①if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:1;
②if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:w(20, 20, 20)
③if a < b and b < c, then w(a, b, c) returns:w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)
④otherwise it returns:w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

解題思路:

直接遞迴必然超時,所以一定要記憶化搜尋。
用dp[a][b][c]記錄w(a,b,c)的值,每次判斷一下如果計算過就不再重複計算,注意防止下標越界的問題,要先處理負數再處理大數。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <bitset>
#include <map>
#include <iomanip>
#include <algorithm>
#define MAXN 21
#define INF 0xfffffff
using namespace std;
/*
if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)
*/
int dp[MAXN][MAXN][MAXN];
int w(int a,int b,int c)
{
    if(a<=0||b<=0||c<=0) return 1;//為了防止下標越界(為負)所以先處理
    if(a>20||b>20||c>20) return dp[20][20][20]=w(20,20,20);//為了防止下標越界(大於20)所以先處理
    if(dp[a][b][c]!=0) return dp[a][b][c];//已經計算過的不再重複計算
    if(a<b&&b<c)  return dp[a][b][c]=(w(a,b,c-1)+w(a,b-1,c-1)-w(a,b-1,c));
    return dp[a][b][c]=(w(a-1,b,c)+w(a-1,b-1,c)+w(a-1, b, c-1)-w(a-1,b-1,c-1));
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("G:/cbx/read.txt","r",stdin);
    //freopen("G:/cbx/out.txt","w",stdout);
#endif
    ios::sync_with_stdio(false);
    cin.tie(0);
    memset(dp,0,sizeof(dp));
    int a,b,c;
    while(cin>>a>>b>>c)
    {
        if(a==-1&&b==-1&&c==-1) break;
        cout<<"w("<<a<<", "<<b<<", "<<c<<") = "<<w(a,b,c)<<endl;
    }
    return 0;
}


相關文章