poj3252 數位dp(所有比n小的二進位制位0的個數不少於1的個數)記憶化搜尋
http://poj.org/problem?id=3252
Description
The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.
They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.
A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.
Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.
Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).
Input
Output
Sample Input
2 12
Sample Output
6
/**
poj 3252 數位dp(所有比n小的二進位制位0的個數不少於1的個數)記憶化搜尋
題目大意:求出區間內二進位制表示是0的個數不小於1的個數的數的個數
解題思路:用記憶化搜尋dfs(len,num0,num1,flag,first)len表示二進位制的位置,num0表示0的個數,flag標記是不是訪問到上限,
first表示第一個1的位置,對於每個這樣的位置開始以後看做一個次二進位制數
http://blog.csdn.net/libin56842/article/details/10037607
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int dp[50][50][50],n,m,bit[50];
int dfs(int len,int num0,int num1,int flag,int first)
{
if(len<0)return num0>=num1;
if(flag==0&&dp[len][num0][num1]!=-1)return dp[len][num0][num1];
int ans=0;
int end=flag?bit[len]:1;
for(int i=0; i<=end; i++)
{
int t=first&&(i==0);
ans+=dfs(len-1,t?0:num0+(i==0),t?0:num1+(i==1),flag&&i==end,t);
}
if(flag==0)dp[len][num0][num1]=ans;
return ans;
}
int solve(int n)
{
int len=0;
while(n)
{
bit[len++]=n%2;
n>>=1;
}
return dfs(len-1,0,0,1,1);
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
memset(dp,-1,sizeof(dp));
printf("%d\n",solve(m)-solve(n-1));
}
return 0;
}
相關文章
- 二進位制中1的個數
- 位運算--求一個 數二進位制中1的個數
- 位運算(一):二進位制中1的個數
- 求一個整數的二進位制中1的個數
- 查詢數N二進位制中1的個數(JS版 和 Java版)JSJava
- 【劍指offer】二進位制中1的個數
- 數位DP小記
- 【c語言】統計一個數二進位制中的1的個數C語言
- 求一個數的二進位制數中所含1的個數的程式碼實現
- 【刷演算法】二進位制中1的個數演算法
- 題目1513:二進位制中1的個數
- 求二進位制數中1的個數(程式設計之美)程式設計
- 劍指 Offer 15. 二進位制中1的個數
- JZ-011-二進位制中 1 的個數
- 負數的二進位制數問題
- 【c語言】將一個數的二進位制序列逆序,然後輸出逆序之後的二進位制序,所對應的數C語言
- 用C#實現二進位制的減法(包括二進位制小數)C#
- C++輸入十進位制數,輸出對應二進位制數、十六進位制數C++
- 根據數字二進位制下 1 的數目排序排序
- 用c語言實現輸入一個十進位制數,計算其轉換為二進位制數後其中包含1的個數C語言
- 產生一個32位的16進位制隨機數隨機
- 對於十進位制數 -1023,包含符號位在內,至少需要多少個二進位制位表示該數符號
- 1417 二進位制數的大小
- N位二進位制數加減法運算圖靈機圖靈
- 【劍指offer中等部分4】二進位制中1的個數(java)Java
- offer通過--10二進位制中統計1的個數-2
- 負數補碼(16進位制轉10進位制的負數)
- .C++整數的N進位制字串表示C++字串
- 03:八進位制小數
- [DP] 數位DP
- 02_Python學習筆記之統計整數二進位制中1的個數Python筆記
- BZOJ3329: Xorequ(二進位制數位dp 矩陣快速冪)矩陣
- 數位 dp
- 數的進位制轉換
- 演算法學習記錄九(C++)--->二進位制中1的個數演算法C++
- 有趣的二進位制3—浮點數
- 十六進位制數轉十進位制
- 對十進位制數字的按位輸出,取反,並求其位數