POJ 1050-To the Max(最大子矩陣和)
To the Max
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 48640 | Accepted: 25719 |
Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the
sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines).
These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
Sample Output
15
Source
題目意思:
N*N矩陣,求其中一個最大的子矩陣使得其和最大。
解題思路:
轉換成一維DP的思路來做,先處理字首和,對於每一列上的元素,當前元素的值加上其前面所有元素的值。
然後參考一維DP的做法,列舉起始和終止行,在列上找最大值。
#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define INF 0xfffffff
#define MAXN 101
int a[MAXN][MAXN];
int b[MAXN];
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("G:/cbx/read.txt","r",stdin);
//freopen("G:/cbx/out.txt","w",stdout);
#endif
ios::sync_with_stdio(false);
cin.tie(0);
int n;
cin>>n;
memset(a,0,sizeof(a));
for(int i=1; i<=n; ++i)
for(int j=1; j<=n; ++j)
{
cin>>a[i][j];
a[i][j]+=a[i-1][j];//列上的元素依次求和
}
/*for(int i=1; i<=n; ++i)
{
for(int j=1; j<=n; ++j)
cout<<a[i][j]<<" ";
cout<<endl;
}*/
int ans=a[1][1];
for(int i=0; i<=n-1; ++i)//起始行
for(int j=i+1; j<=n; ++j)//終止行
{
memset(b,0,sizeof(b));//第i~j行k列中能取得的最大值
for(int k=1; k<=n; ++k)//當前列舉的列
{
if(b[k-1]>=0) b[k]=b[k-1]+a[j][k]-a[i][k];
else b[k]=a[j][k]-a[i][k];
ans=max(ans,b[k]);
}
}
cout<<ans<<endl;
}
相關文章
- #1502 : 最大子矩陣矩陣
- POJ 3613 Cow Relays 矩陣乘法Floyd+矩陣快速冪矩陣
- 第四章:多維陣列和矩陣 ------------- 4.4 找出邊界為1的最大子方陣陣列矩陣
- 53. 最大子陣列和陣列
- 矩陣和陣列矩陣陣列
- Max/MSP/Jitter 官方教程翻譯11 - 矩陣混合矩陣
- LeetCode53. 最大子陣列和LeetCode陣列
- [Python手撕]最大子陣列和Python陣列
- 【力扣】最大子陣列和(貪心)力扣陣列
- 求二維陣列中最大子陣列的和陣列
- poj--2778DNA Sequence+AC自動機+矩陣快速冪矩陣
- 最大連續子陣列和(最大子段和)陣列
- 伴隨矩陣和逆矩陣的關係證明矩陣
- 第四章:多維陣列和矩陣 ------------- 4.8 子矩陣的最大累加和陣列矩陣
- 資料結構之陣列和矩陣--矩陣&不規則二維陣列資料結構陣列矩陣
- 巨大的矩陣(矩陣加速)矩陣
- 鄰接矩陣、度矩陣矩陣
- POJ 3233 Matrix Power Series (矩陣快速冪+等比數列二分求和)矩陣
- 奇異矩陣,非奇異矩陣,偽逆矩陣矩陣
- Max/MSP/Jitter 官方教程翻譯05 - 矩陣的數學運算矩陣
- 矩陣的最短距離和矩陣
- 資料結構:陣列,稀疏矩陣,矩陣的壓縮。應用:矩陣的轉置,矩陣相乘資料結構陣列矩陣
- 【刷題筆記】LeetCode-53 最大子陣列和筆記LeetCode陣列
- 矩陣矩陣
- 求任意矩陣的伴隨矩陣矩陣
- 【DP】乘積最大子陣列陣列
- 廣州C++信奧老師解一本通題 1260:1282:最大子矩陣C++矩陣
- 矩陣的特徵值和特徵向量矩陣特徵
- 240. 搜尋二維矩陣 II 和74. 搜尋二維矩陣矩陣
- 理解矩陣矩陣
- 海浪矩陣矩陣
- 矩陣相乘矩陣
- 稀疏矩陣矩陣
- 螺旋矩陣矩陣
- 矩陣乘法矩陣
- 8.6 矩陣?矩陣
- 找矩陣矩陣
- 矩陣分解矩陣
- 快手矩陣管理平臺,矩陣管理有方法矩陣