指標-矩陣下三角元素之和

HowieLee59發表於2019-03-16

Problem Description

輸入一個正整數n(1<=n<=10),再輸入n*n的矩陣,要求求該矩陣的下三角元素之和。

Input

輸入包括n+1行。
第一行為整數n;
接下來的n行為矩陣資料。

Output

矩陣的下三角元素之和。

Sample Input

5
1 2 3 4 5
2 3 4 5 6
3 4 5 6 7
4 5 6 7 8
5 6 7 8 9

Sample Output

75
#include<stdio.h>
#include<stdlib.h>

int main(){
    int a;
    int c[100][100];
    scanf("%d",&a);
    for(int i = 0 ; i < a; i++){
        for(int j = 0 ; j < a ; j++){
            scanf("%d",&c[i][j]);
        }
    }
    int count = 0;
    for(int i = 0 ; i < a ; i++){
        for(int j = 0 ; j <= i ; j++){
            count += *(*(c + i)+ j);
            //printf("%d c[%d][%d]\n",count,i,j);
        }
    }
    //printf("%d",count);
}

 

相關文章