順序表應用6:有序順序表查詢

HowieLee59發表於2019-01-26

Problem Description

順序表內按照由小到大的次序存放著n個互不相同的整數,任意輸入一個整數,判斷該整數在順序表中是否存在。如果在順序表中存在該整數,輸出其在表中的序號;否則輸出“No Found!"。

Input

 第一行輸入整數n (1 <= n <= 100000),表示順序表的元素個數;
第二行依次輸入n個各不相同的有序非負整數,代表表裡的元素;
第三行輸入整數t (1 <= t <= 100000),代表要查詢的次數;
第四行依次輸入t個非負整數,代表每次要查詢的數值。

保證所有輸入的數都在 int 範圍內。

Output

 輸出t行,代表t次查詢的結果,如果找到在本行輸出該元素在表中的位置,否則本行輸出No Found!

Sample Input

10
1 22 33 55 63 70 74 79 80 87
4
55 10 2 87

Sample Output

4
No Found!
No Found!
10

Hint

Source

這個題原本用STL中的map來做,結果爆了記憶體--

原本的程式碼:

//ios::sync_with_stdio(false);
#include<iostream>
#include<stdlib.h>
#include<map>
#include<stdio.h>
#define MaxSize 100001

using namespace std;
typedef int element;
typedef struct List{
    element data[MaxSize];
    int size;
}list;
map<int,int> m;

void init(list &l,int a){
    int i = 0;
    for(i = 0 ; i < a;i++){
        l.data[i] = 0;
    }
    l.size = a;
}

void input(list &l,int a){
    int j;
    for(int i = 0 ; i < a;i++){
        cin >> j;
        l.data[i] = j;
        //test.insert(pair<int, string>(1, "test"));
        m.insert(pair<int,int>(j,i+1));
        //printf("%d\n",l.data[i]);
    }
}


void output(int b){
    int i;
    int c;
    for(i = 0; i < b;i++){
        cin >> c;
        map<int, int>::iterator iter;
        iter = m.find(c);
        //printf("%d\n",iter->second);
        if (iter != m.end()){
            printf("%d\n",iter->second);
        }
        else{
            printf("No Found!\n");
        }
    }
}

int main(){
    ios::sync_with_stdio(false);
    int a,b;
    list l;
    cin >> a;
    init(l,a);
    input(l,a);
    cin >> b;
    output(b);
}

看其他人的部落格得知需要用二分法

#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <stdio.h>
using namespace std;

int n, m;
#define maxsize 10000010
typedef int element;
typedef struct
{
    element * elem;
    int length;
    int listsize;
}sq;

int Inlist(sq & l)
{
    l.elem = (element * )malloc(maxsize * sizeof(element));
    if(!l.elem)
        return -1;
    l.length = 0;
    l.listsize = maxsize;
    return 0;
}

void creat(sq & l)
{
    for(int i = 0 ; i < n; i++)
        cin >> l.elem[i];
    l.length = n;
}

void find(sq & l, int s, int t, int key)
{
    int low = s, high = t;
    if(s <= t)
    {
        int mid = low + (high - low) / 2;
        if(l.elem[mid] == key)
        {
            cout << mid + 1 << endl;
            return;
        }
        if(l.elem[mid] > key)
            find(l, low, mid - 1, key);
        else
            find(l, mid + 1, high, key);
    }
    if(s > t)
        cout << "No Found!" << endl;
}


int main()
{
    ios::sync_with_stdio(false);            //加速輸入輸出,不然用scanf printf
    sq l;
    int t, x;
    cin >> n;
    Inlist(l);
    creat(l);
    cin >> t;
    while(t--)
    {
        cin >> x;
        find(l, 0, n - 1, x);
    }
    return 0;
}

時間複雜度為O(logN)

相關文章