順序表應用1:多餘元素刪除之移位演算法

HowieLee59發表於2019-01-25

 

Problem Description

一個長度不超過10000資料的順序表,可能存在著一些值相同的“多餘”資料元素(型別為整型),編寫一個程式將“多餘”的資料元素從順序表中刪除,使該表由一個“非純表”(值相同的元素在表中可能有多個)變成一個“純表”(值相同的元素在表中只保留第一個)。
要求:
       1、必須先定義線性表的結構與操作函式,在主函式中藉助該定義與操作函式呼叫實現問題功能;
       2、本題的目標是熟悉順序表的移位演算法,因此題目必須要用元素的移位實現刪除;

Input

 第一行輸入整數n,代表下面有n行輸入;
之後輸入n行,每行先輸入整數m,之後輸入m個資料,代表對應順序表的每個元素。

Output

 輸出有n行,為每個順序表刪除多餘元素後的結果

Sample Input

4
5 6 9 6 8 9
3 5 5 5
5 9 8 7 6 5
10 1 2 3 4 5 5 4 2 1 3

Sample Output

6 9 8
5
9 8 7 6 5
1 2 3 4 5

這個題的主要思路是:兩重for迴圈,找到重複元素之後將排在後面的元素之後的數前移,並將長度減一。

在做題的過程中遇到了:error: expected ';', ',' or ')' before '&' token 

經過查詢後得知,可以用指標來代替引用,在主函式中傳進來地址;或者是使用C++來進行編譯。

程式碼如下:

#include<iostream>
#include<stdio.h>
#define listMax 100000

using namespace std;

typedef int element;
typedef struct{
    element *elem;
    int length;
    int listSize;
}Elemlist;

void creat(Elemlist &L,int n){
    L.elem = new int[listMax];
    L.length = n;
    L.listSize = listMax;
}

void input(Elemlist &L){
    int i;
    for(i = 0 ; i < L.length;i++){
        scanf("%d",&L.elem[i]);
    }
}

void del(Elemlist &L,int j){
    int i;
    for(i = j ; i < L.length;i++){
        L.elem[i] = L.elem[i + 1];
    }
    L.length--;
}

void compare(Elemlist &L){
    int i,j;
    for(i = 0; i < L.length - 1;i++){
        for(j = i + 1;j < L.length; j++){
            if(L.elem[i] == L.elem[j]){
                del(L,j);
                j--;
            }
        }
    }
}

void output(Elemlist &L){
    int i;
    for(i = 0; i < L.length - 1;i++){
        printf("%d ",L.elem[i]);
    }
    printf("%d\n",L.elem[i]);
}

int main(){
    Elemlist L;
    int a,b;
    scanf("%d",&a);
    while(a--){
        scanf("%d",&b);
        creat(L,b);
        input(L);
        compare(L);
        output(L);
    }
    return 0;
}

寒假的時間刷完!

相關文章