順序表應用2:多餘元素刪除之建表演算法

HowieLee59發表於2019-01-25

Problem Description

一個長度不超過10000資料的順序表,可能存在著一些值相同的“多餘”資料元素(型別為整型),編寫一個程式將“多餘”的資料元素從順序表中刪除,使該表由一個“非純表”(值相同的元素在表中可能有多個)變成一個“純表”(值相同的元素在表中只保留第一個)。
要求:
       1、必須先定義線性表的結構與操作函式,在主函式中藉助該定義與操作函式呼叫實現問題功能;
       2、本題的目標是熟悉在順序表原表空間基礎上建新表的演算法,要在原順序表空間的基礎上完成完成刪除,建表過程不得開闢新的表空間;
       3、不得采用原表元素移位刪除的方式。

Input

 第一行輸入整數n,代表下面有n行輸入;
之後輸入n行,每行先輸入整數m,之後輸入m個資料,代表對應順序表的每個元素。

Output

  輸出有n行,為每個順序表刪除多餘元素後的結果

Sample Input

4
5 6 9 6 8 9
3 5 5 5
5 9 8 7 6 5
10 1 2 3 4 5 5 4 2 1 3

Sample Output

6 9 8
5
9 8 7 6 5
1 2 3 4 5

Hint

 

Source

這個題的時間和空間都卡的很緊,所以用第一個中的刪除的會超時和超空間,所以每次在加入之前都判斷下陣列中是否存在,如果存在那麼就不加入,相對應的把下表提前。

#include<iostream>
#include<stdio.h>
#define MaxSize 100000
using namespace std;

typedef int element;
typedef struct node{
    int data[MaxSize];
    int last;
}list;

void init(list &L,int b){
    int i;
    for(i = 0 ; i < b;i++){
        L.data[i] = 0;
    }
    L.last = b;
}

void CreatDel(list &L){
    int i,j;
    scanf("%d",&L.data[0]);
    for(i = 1 ;i < L.last;i++){
        scanf("%d",&L.data[i]);
        //printf("%d \n",L.data[i]);
        for(j = 0; j < i;j++){
            if(L.data[j] == L.data[i]){
                i--;
                L.last--;
            }
        }
    }
}

void output(list &L){
    int i;
    for(i = 0 ; i < L.last - 1;i++){
        printf("%d ",L.data[i]);
    }
    printf("%d\n",L.data[i]);
}

int main(){
    list L;
    int a,b;
    scanf("%d",&a);
    while(a--){
        scanf("%d",&b);
        init(L,b);
        CreatDel(L);
        output(L);
    }
    return 0;
}

 

相關文章