HDU 3183 A Magic Lamp (RMQ)

Mr_Treeeee發表於2020-04-06

A Magic Lamp

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4268    Accepted Submission(s): 1765


Problem Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams. 
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
 

Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
 

Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it. 
 

Sample Input
178543 4 1000001 1 100001 2 12345 2 54321 2
 

Sample Output
13 1 0 123 321
 

Source
 

題意:

給你一串數和m,刪m個數,使刪後的數最小。

POINT:

RMQ,每次找最小的數,注意查詢的區間,要保證查詢到的數後面還必須有數可以找(除非是最後一個)。注意一下這個即可。

第一次寫RMQ,陣列越界了好久。

for(int i=0;i+(1<<j)-1 < n;i++)

寫成

for(int i=0;i<n;i++)

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
using namespace std;
#define LL long long
const int  N  = 1200;
char s[N];
int m,n;
int dp[N][30];
int ans[N];
int Min(int a,int b)
{
    return s[a]>s[b]?b:a;
}
void preRMQ()
{
    for(int i=0;i<n;i++)
    {
        dp[i][0]=i;
    }
    for(int j=1;1<<j<n;j++)
    {
        for(int i=0;i+(1<<j)-1 < n;i++)
        {
            dp[i][j]=Min(dp[i][j-1],dp[i+(1<<j-1)][j-1]);
        }
    }
}
int query(int l,int r)
{
    int k=(int)log2((double)(r-l+1));
    return Min(dp[l][k],dp[r+1-(1<<k)][k]);
}

int main()
{
    while(cin>>s>>m)
    {
        n=strlen(s);
        memset(dp,0,sizeof dp);
        preRMQ();
        int now=0;
        memset(ans,0,sizeof ans);
        m=n-m;
        for(int i=m;i>0;i--)
        {
            int pos=query(now,n-i);
            ans[i]=s[pos]-'0';
            now=pos+1;
        }
        int i;
        for(i=m;i>0;i--)
        {
            if(ans[i]!=0)
                break;
        }
        if(i==0) printf("0");
        for(int j=i;j>0;j--)
        {
            printf("%d",ans[j]);
        }
        printf("\n");
    }

}


相關文章