統計母音 hd 2027
Problem Description
統計每個母音字母在字串中出現的次數。
Input
輸入資料首先包括一個整數n,表示測試例項的個數,然後是n行長度不超過100的字串。
Output
對於每個測試例項輸出5行,格式如下:
a:num1
e:num2
i:num3
o:num4
u:num5
多個測試例項之間由一個空行隔開。
請特別注意:最後一塊輸出後面沒有空行:)
Sample Input
2
aeiou
my name is ignatius
Sample Output
a:1
e:1
i:1
o:1
u:1
a:2
e:1
i:3
o:0
u:1
#include<stdio.h>
#include<string.h>
int main()
{
int n,c,d,e,f,g,i,b;
char a[110];
scanf("%d",&n);
getchar();
while(n--)
{
c=0;
d=0;
e=0;
f=0;
g=0;
gets(a);
b=strlen(a);
for(i=0;i<b;i++)
{
if(a[i]=='a') c++;
if(a[i]=='e') d++;
if(a[i]=='i') e++;
if(a[i]=='o') f++;
if(a[i]=='u') g++;
}
printf("a:%d\n",c);
printf("e:%d\n",d);
printf("i:%d\n",e);
printf("o:%d\n",f);
printf("u:%d\n",g);
if(n) printf("\n");<span style="white-space:pre"> </span>//後面是兩個空行
}
}
相關文章
- 字串統計 hd 2017字串
- leetcode 深度搜尋 1641.統計字典序母音字串的數目LeetCode字串
- Problem F: 是母音字母嗎?
- win10系統hd color模式有什麼用_win10系統hd color模式使用教程Win10模式
- LeetCode-345-反轉字串中的母音字母LeetCode字串
- Picture hd 2052
- IDC:預計2027年的量子計算支出將達86億美元
- 密碼 hd 2043密碼
- Big Number hd 1212
- the Sum of Cube hd 5053
- 不要62 hd 2089
- 預計2027年電動汽車的生產成本將會低於同型別傳統燃油車型別
- 預計2027年AI伺服器市場達1520億美元AI伺服器
- LeetCode每日一題: 反轉字串中的母音字母(No.345)LeetCode每日一題字串
- 偶數求和 hd 2015
- 剪花布條hd 2087
- 1sting hd 1865
- A + B Problem II hd 1002
- 母牛的故事 hd 2018
- 18歲生日 hd 1201
- 美素數 hd 4548
- 素數判定 hd 2012
- 又見GCD hd 2504GC
- Canalys:預計2027年AI手機市場份額將達45%AI
- 預計2027年全球AI耗水將達66億立方米AI
- HD Tune軟體怎麼用?使用HD tune檢測硬碟的方法教程硬碟
- Lowest Common Multiple Plus hd 2028
- 海選女主角 hd 2022
- 多項式求和 hd 2011
- 求平均成績 hd 2023
- 折線分割平面 hd 2050
- 無限的路 hd 2073
- 整除的尾數 hd 2099
- 大菲波數 hd 1715
- 超級樓梯 hd 2041
- 最小公倍數 hd 1108
- Omdia:預計2027年全球消費者遊戲支出達到2150億美元遊戲
- Yole:預計2027年全球電動機市場將超過130億美元