1sting hd 1865

q923714892發表於2020-04-06
Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.



Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.



Output
The output contain n lines, each line output the number of result you can get .



Sample Input
3
1
11
11111


Sample Output
1
2

8

#include <stdio.h>
#include <string.h>
int str1[210][300]={{0}};
int main()
{
    int n;
    scanf("%d",&n);
    getchar();
    while(n--)
    {
        char str[300];
        gets(str);
        int len=strlen(str);
        str1[0][0]=1;
        str1[1][0]=2;
        for(int i=2;i<len;i++)
        {
            int c=0,k;
            for(k=0;k<300;k++)
            {
                int s=str1[i-1][k]+str1[i-2][k]+c;
                str1[i][k]=s%10;
                c=s/10;
            }
            while(c)
            {
                str1[i][k++]=c%10;
                c/=10;
            }
        }
        int i;
        for(i=299;i>=0;i--)
            if(str1[len-1][i])
                break;
        for(int j=i;j>=0;j--)
            printf("%d",str1[len-1][j]);
        printf("\n");
    }
    return 0;
}
 



相關文章