Picture hd 2052

q923714892發表於2020-04-06
Picture
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8193 Accepted Submission(s): 4287
Problem Description
Give you the width and height of the rectangle,darw it.
Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.

Sample Input
3 2
Sample Output
+---+
|      |
|      |

+---+

#include<stdio.h>
int main()
{
	int a,b,i,j;
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		printf("+");
		for(i=0;i<a;i++)
		printf("-");
		printf("+");
		printf("\n");
		for(i=0;i<b;i++)
		{
			printf("|");
			for(j=0;j<a;j++)
			printf(" ");
			printf("|");
			printf("\n");
		}
		printf("+");
		for(i=0;i<a;i++)
		printf("-");
		printf("+");
		printf("\n");
		printf("\n");
	}
	return 0;
}