整除的尾數 hd 2099

q923714892發表於2020-04-06
Problem Description
一個整數,只知道前幾位,不知道末二位,被另一個整數除盡了,那麼該數的末二位該是什麼呢?


Input
輸入資料有若干組,每組資料包含二個整數a,b(0<a<10000, 10<b<100),若遇到0 0則處理結束。


Output
對應每組資料,將滿足條件的所有尾數在一行內輸出,格式見樣本輸出。同組資料的輸出,其每個尾數之間空一格,行末沒有空格。


Sample Input
200 40
1992 95
0 0


Sample Output
00 40 80

15

#include<stdio.h>
int main()
{
int a,b,i,j,c,f;
int d[110];
int e[110];
while(scanf("%d%d",&a,&b)!=EOF)
{
f=0;
if(a==0&&b==0)break;
for(i=0;i<10;i++)
{
for(j=0;j<10;j++)
{
c=100*a+10*i+j;
if(c%b==0)
{
d[f]=i;
e[f]=j;
f=f+1;
}
}
}
printf("%d%d",d[0],e[0]);
for(i=1;i<f;i++)
{
printf(" %d%d",d[i],e[i]);
}
printf("\n");
}
return 0;
}


相關文章