首字母變大寫 hd 2026

q923714892發表於2020-04-06
Problem Description
輸入一個英文句子,將每個單詞的第一個字母改成大寫字母。



Input
輸入資料包含多個測試例項,每個測試例項是一個長度不超過100的英文句子,佔一行。



Output
請輸出按照要求改寫後的英文句子。



Sample Input
i like acm
i want to get an accepted


Sample Output
I Like Acm

I Want To Get An Accepted

#include<stdio.h>
#include<string.h>
int main()
{
	char a[100];
	int b,i;
	while(gets(a)) <span style="white-space:pre">		</span>//不能用scanf scanf不能識別空格
	{
		b=strlen(a);
		if(a[0]>96&&a[0]<123)	a[0]=a[0]-32;
		for(i=0;i<b;i++)
		{
			if(a[i]==' ')
			a[i+1]=a[i+1]-32;
		}
		for(i=0;i<b;i++)
		{
		printf("%c",a[i]);
		}
		printf("\n");
	}
	return 0;
}


相關文章