YT15-HDU-字串的模擬

不被看好的青春叫成長發表於2015-03-07

Problem Description

 

As you know, when you want to hack someone's program, you must submit your test data. However sometimes you will submit invalid data, so we need a data checker to check your data. Now small W has prepared a problem for BC, but he is too busy to write the data checker. Please help him to write a data check which judges whether the input is an integer ranged from a to b (inclusive).
Note: a string represents a valid integer when it follows below rules.
1. When it represents a non-negative integer, it contains only digits without leading zeros.
2. When it represents a negative integer, it contains exact one negative sign ('-') followed by digits without leading zeros and there are no characters before '-'.
3. Otherwise it is not a valid integer.

 

Input

 

Multi test cases (about 100), every case occupies two lines, the first line contain a string which represents the input string, then second line contains a and b separated by space. Process to the end of file.

Length of string is no more than 100.
The string may contain any characters other than '\n','\r'.
-1000000000$\leq a \leq b \leq 1000000000$

 

Output

 

For each case output "YES" (without quote) when the string is an integer ranged from a to b, otherwise output "NO" (without quote).

 

Sample Input

 

10
-100 100
1a0
-100 100

 

Sample Output

 

YES
NO

 

程式碼如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
int main()
{
    char str[200],cp[200];
    int a,b;
    while(gets(str))
    {
        cin>>a>>b;
        getchar();
        int x=atoi(str);//把字串轉換成長整型數的一個函式,標頭檔案是#include <cstdlib>
        sprintf(cp,"%d",x);//字串格式化命令,主要功能是把格式化的資料寫入某個字串中,標頭檔案是#include <cstdlib>
        if(strcmp(str,cp)==0 && x>=a && x<=b)//比較函式,標頭檔案是#include <cstring>
           cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}


執行結果:

 

程式碼不是我寫的,問了一個做了的同學才知道大神都是用函式庫做題的,繼續努力吧!!!

相關文章