Ignatius and the Princess IV——伊格納提烏斯和四公主
Problem Description"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.
InputThe input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
Output
Sample Input
Sample Output
Author
|
題意:
問題描述
"好吧,你不是太壞,嗯...但你永遠不能通過下一個測試。"馮5166說。
"我會告訴你一個奇數n,然後n個整數。其中會有個特殊的整數,在我告訴你所有的整數之後,你必須告訴我哪個是特殊的整數。”馮5166說。
"但是特殊整數的特性是什麼?"他問。
"整數至少會出現(n+1)/2次。如果你找不到合適的整數,我會殺了公主,你也會成為我的晚餐。“馮5166說。
你能為伊格納提找到一個特殊的整數嗎?
輸入:
輸入包含幾個測試用例。每個測試用例包含兩行。第一行由奇數整數n(1<=n<=999999)組成,這表示整數的數目,馮5166將告訴我們的英雄。第二行包含n個整數。輸入在檔案結束時終止。
輸出:
對於每個測試用例,您只能輸出一行,其中包含您找到的特殊編號。
AC碼:
方法一:
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1000000;
int a[maxn];
int main()
{
int n;
while(~scanf("%d",&n))
{
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
sort(a,a+n);
printf("%d\n",a[n/2]);
}
return 0;
}
方法二:
#include<stdio.h>
#include<string.h>
int map[500001];//記錄[i]出現的次數
int main()
{
int n,i,a,max;
while(scanf("%d",&n)!=EOF)
{
memset(map,0,sizeof(map));
for(i=0;i<n;i++)
{
scanf("%d",&a);
map[a]++;
if(map[a]>=(n+1)/2)
max=a;
}
printf("%d\n",max);
}
return 0;
}
相關文章
- Ignatius and the Princess II
- HDU 母函式簡單題 - 找單詞/Ignatius and the Princess III/Square Coins/Holding Bin-Laden Captive!函式APT
- 莫比烏斯
- 莫比烏斯反演
- 莫比烏斯函式函式
- The Princess And The Pea
- 伊萊克斯空調全國各市售後服務熱線電話官方客服熱線伊萊克斯
- Kotlin知識歸納(四) —— 介面和類Kotlin
- Hackerrank GCD Product(莫比烏斯反演)GC
- 鹿特丹伊拉斯姆斯大學:研究發現智慧手機會損害孩子眼睛和聽力
- 比較典的莫比烏斯反演
- 莫比烏斯反演學習筆記筆記
- Problem H. Curious (莫比烏斯反演)
- 烏龍茶供應價格
- 莫比烏斯函式 - 學習筆記函式筆記
- [提問交流]tortoisegit 小烏龜無法git pullGit
- 2018世界盃烏拉圭vs俄羅斯誰會贏 烏拉圭vs俄羅斯比分預測
- 8.dfs--王子救公主(遍歷迷宮,王子和公主訪問過同一位置,即成功救公主)
- 納斯達克戰勝區塊鏈!!區塊鏈
- 狄利克雷卷積 & 莫比烏斯反演卷積
- SAP MM GR-based IV, 無GR不能IV?
- Eastmount部落格導讀:專欄系統分類和部落格歸納總結AST
- 狄利克雷卷積與莫比烏斯反演卷積
- 演算法隨筆——數論之莫比烏斯反演演算法
- 洛谷 P2257 YY的GCD(莫比烏斯反演)GC
- cf900D. Unusual Sequences(容斥 莫比烏斯反演)
- Java加密之IVJava加密
- 伊抹
- L1 和L2(Frobenius弗羅貝尼烏斯)正則化複習筆記筆記
- “DNF心悅精英賽”直播預告:下一站普雷•伊西斯
- IV. Mip-NeRF
- SDOI2018 反迴文串(莫比烏斯反演+Pollard-Rho)
- 烏克蘭新法案提議徵收5%的加密貨幣收入稅加密
- 納斯達克交易所將Long Blockchain股票停牌Blockchain
- 東方美人白毫烏龍茶-供應價格
- 瞄準烏克蘭政府和軍事網路,俄羅斯APT黑客團體再發新攻擊APT黑客
- 第一性原則:伊隆·馬斯克(Elon Musk)論自我思考的力量 - jamesclear馬斯克
- 《伊拉圖斯死之主》:硬核遊戲也有相對放鬆的遊戲體驗遊戲