hdu4280 網路流+掛(無向圖的網路流注意建邊)
http://acm.hdu.edu.cn/showproblem.php?pid=4280
Problem Description
In the vast waters far far away, there are many islands. People are living on the islands, and all the transport among the islands relies on the ships.
You have a transportation company there. Some routes are opened for passengers. Each route is a straight line connecting two different islands, and it is bidirectional. Within an hour, a route can transport a certain number of passengers in one direction. For safety, no two routes are cross or overlap and no routes will pass an island except the departing island and the arriving island. Each island can be treated as a point on the XY plane coordinate system. X coordinate increase from west to east, and Y coordinate increase from south to north.
The transport capacity is important to you. Suppose many passengers depart from the westernmost island and would like to arrive at the easternmost island, the maximum number of passengers arrive at the latter within every hour is the transport capacity. Please calculate it.
You have a transportation company there. Some routes are opened for passengers. Each route is a straight line connecting two different islands, and it is bidirectional. Within an hour, a route can transport a certain number of passengers in one direction. For safety, no two routes are cross or overlap and no routes will pass an island except the departing island and the arriving island. Each island can be treated as a point on the XY plane coordinate system. X coordinate increase from west to east, and Y coordinate increase from south to north.
The transport capacity is important to you. Suppose many passengers depart from the westernmost island and would like to arrive at the easternmost island, the maximum number of passengers arrive at the latter within every hour is the transport capacity. Please calculate it.
Input
The first line contains one integer T (1<=T<=20), the number of test cases.
Then T test cases follow. The first line of each test case contains two integers N and M (2<=N,M<=100000), the number of islands and the number of routes. Islands are number from 1 to N.
Then N lines follow. Each line contain two integers, the X and Y coordinate of an island. The K-th line in the N lines describes the island K. The absolute values of all the coordinates are no more than 100000.
Then M lines follow. Each line contains three integers I1, I2 (1<=I1,I2<=N) and C (1<=C<=10000) . It means there is a route connecting island I1 and island I2, and it can transport C passengers in one direction within an hour.
It is guaranteed that the routes obey the rules described above. There is only one island is westernmost and only one island is easternmost. No two islands would have the same coordinates. Each island can go to any other island by the routes.
Then T test cases follow. The first line of each test case contains two integers N and M (2<=N,M<=100000), the number of islands and the number of routes. Islands are number from 1 to N.
Then N lines follow. Each line contain two integers, the X and Y coordinate of an island. The K-th line in the N lines describes the island K. The absolute values of all the coordinates are no more than 100000.
Then M lines follow. Each line contains three integers I1, I2 (1<=I1,I2<=N) and C (1<=C<=10000) . It means there is a route connecting island I1 and island I2, and it can transport C passengers in one direction within an hour.
It is guaranteed that the routes obey the rules described above. There is only one island is westernmost and only one island is easternmost. No two islands would have the same coordinates. Each island can go to any other island by the routes.
Output
For each test case, output an integer in one line, the transport capacity.
Sample Input
2
5 7
3 3
3 0
3 1
0 0
4 5
1 3 3
2 3 4
2 4 3
1 5 6
4 5 3
1 4 4
3 4 2
6 7
-1 -1
0 1
0 2
1 0
1 1
2 3
1 2 1
2 3 6
4 5 5
5 6 3
1 4 6
2 5 5
3 6 4
Sample Output
9
6
/**
hdu 4280 網路流+掛
題目大意:給出一些點從最西邊的點經過網路到最東邊的點,問最大流量(無向圖)
解題思路:無向圖網路流,不過無向圖建邊要正反向都要賦予流量值,如果有向圖則正向流量值,反向為0;
*/
#pragma comment(linker, "/STACK:10240000000000,10240000000000")
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <string.h>
using namespace std;
const int oo=1e9;
const int mm=200051;
const int mn=100005;
int node,src,dest,edge;
int ver[mm],flow[mm],_next[mm];
int head[mn],work[mn],dis[mn],q[mn];
void prepare(int _node,int _src,int _dest)
{
node=_node,src=_src,dest=_dest;
for(int i=0; i<node; ++i)head[i]=-1;
edge=0;
}
void addedge(int u,int v,int c)
{
ver[edge]=v,flow[edge]=c,_next[edge]=head[u],head[u]=edge++;
ver[edge]=u,flow[edge]=c,_next[edge]=head[v],head[v]=edge++;
}
bool Dinic_bfs()
{
int i,u,v,l,r=0;
for(i=0; i<node; ++i)dis[i]=-1;
dis[q[r++]=src]=0;
for(l=0; l<r; ++l)
for(i=head[u=q[l]]; i>=0; i=_next[i])
if(flow[i]&&dis[v=ver[i]]<0)
{
dis[q[r++]=v]=dis[u]+1;
if(v==dest)return 1;
}
return 0;
}
int Dinic_dfs(int u,int exp)
{
if(u==dest)return exp;
for(int &i=work[u],v,tmp; i>=0; i=_next[i])
if(flow[i]&&dis[v=ver[i]]==dis[u]+1&&(tmp=Dinic_dfs(v,min(exp,flow[i])))>0)
{
flow[i]-=tmp;
flow[i^1]+=tmp;
return tmp;
}
return 0;
}
int Dinic_flow()
{
int i,ret=0,delta;
while(Dinic_bfs())
{
for(i=0; i<node; ++i)work[i]=head[i];
while(delta=Dinic_dfs(src,oo))ret+=delta;
}
return ret;
}
int n,m;
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
int a,b;
int maxx=-1,minn=0x3f3f3f3f;
for(int i=1;i<=n;i++)
{
int x,y;
scanf("%d%d",&x,&y);
if(maxx<x)
{
maxx=x;
b=i;
}
if(minn>x)
{
minn=x;
a=i;
}
}
prepare(n+1,a,b);
for(int i=0;i<m;i++)
{
int u,v,w;
scanf("%d%d%d",&u,&v,&w);
addedge(u,v,w);
}
int ans=Dinic_flow();
printf("%d\n",ans);
}
return 0;
}
相關文章
- 圖論——網路流圖論
- 【網路流】網路流基本概念
- 圖的匹配與網路流
- 網路流
- 網路流&費用流&二分圖
- 網路流初步
- 關於網路流
- 網路流總結
- 網路流最大流
- 網路流相關
- 網路流-最小割
- 上下界網路流
- hdu4975 網路流及‘刪邊法’判是否為唯一流
- 網路流大雜燴
- 【模板】網路流最大流
- 網路流概念補充
- 【自用】有上下界的網路流
- 網路流練習筆記筆記
- 【學習筆記】網路流筆記
- 【筆記/模板】網路流初步筆記
- 網路流學習筆記筆記
- 網路流(最大流,最小割)
- 2.27 二分圖與網路流複習
- 網路流複雜度證明複雜度
- Contest5400 - 網路流-1
- 無邊界網路的劃分建立
- “有容乃大”的Cisco“無邊界網路”
- 無線網路安全的九項注意
- 時間流網際網路之未來(上)
- 【網路流】有源匯上下界最大流
- 狀壓 + 網路流 -- Escape HDU - 3605
- 簡單講講上下界網路流
- P3376 網路流【模板】
- 【網路協議】TCP的互動資料流和成塊資料流協議TCP
- 網路通訊1:位元組流的封裝封裝
- 在邊緣構建智慧網路的未來
- GaussDB(DWS)網路流控與管控效果
- 電信網路拓撲圖自動佈局之匯流排