hdu3001 狀態壓縮dp+三進位制

life4711發表於2014-10-28

http://acm.hdu.edu.cn/showproblem.php?pid=3001

Problem Description
After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn't want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.
 

Input
There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.
 

Output
Output the minimum fee that he should pay,or -1 if he can't find such a route.
 

Sample Input
2 1 1 2 100 3 2 1 2 40 2 3 50 3 3 1 2 3 1 3 4 2 3 10
 

Sample Output
100 90 7
/**
hdu3001  狀態壓縮dp+三進位制。
每個頂點經過最多2次,也就是說有0,1,2三總狀態,我們狀態轉移的時候要用三進位制。另外起點任意,
所以dp[bit[i]][i]=0,剩下的初始化為INF。狀態轉移方程為:dp[next][l] = min(dp[next][l], dp[i][j] + load[j][l]);
其中( next = i + bit[l])。
三進位制沒有對應的移位操作因此我們要模擬實現:首先把0~3^10之間的所有數都用一個陣列num[i][j]表示出來,
1~10位分別代表i化為三進位制後每個位上對應的值(第一位對應個位,第10位對應最高位),然後狀態轉移就可以了
*/

#include<stdio.h>
#include<string.h>
#include<iostream>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;

int n, m, minn;
int load[12][12];
int bit[11] = {1, 3, 9, 27, 81, 243, 729, 2187, 6561, 19683, 59049};
int dp[60000][12];
int num[60000][12];//記錄每個數的三進位制數

void make_trb()//計算所有數的三進製表示
{
    for(int i = 0; i < bit[10]; i++)
    {
        int b = i;
        for(int j = 0; j < 10; j++)
        {
            num[i][j] = b % 3;
            b /= 3;
        }
    }
}

int main()
{
    make_trb();//計算所有數的三進製表示
    while(~scanf("%d%d", &n, &m))
    {
        memset(load, -1, sizeof(load));
        for(int i = 0; i < m; i++)
        {
            int a,b,c;
            scanf("%d%d%d", &a, &b, &c);
            if(load[a-1][b-1] == -1)//去重邊
                load[b-1][a-1] = load[a-1][b-1] = c;
            else
                load[b-1][a-1] = load[a-1][b-1] = min(load[a-1][b-1], c);
        }
        memset(dp,0x3f3f3f3f,sizeof(dp));
        for(int j = 0; j < n; j++)
            dp[ bit[j] ][j] = 0;//對每個點定為初始點0
        int flag,next;
        minn = INF;
        for(int i = 0; i < bit[n]; i++)
        {
            flag = 1;//表示所有位都為1,即所有的城市都遍歷過1次以上
            for(int j = 0; j < n; j++)//跟二進位制一樣遍歷所有終點
            {
                if(num[i][j] == 0)
                    flag = 0;
                if(dp[i][j] == INF)
                    continue;
                for(int l = 0; l < n; l++)
                {
                    if(j == l || num[i][l] >= 2 || load[l][j] == -1)
                        continue;
                    next = i + bit[l];
                    dp[next][l] = min(dp[next][l], dp[i][j] + load[j][l]);
                }//由於跟訪問路徑有關,所以for l 0 -> n,用來歷遍所有起點
            }
            if(flag == 1)
            {
                for(int j = 0; j < n; j++)
                    minn = min(minn , dp[i][j]);
            }
        }
        if(minn == INF)
            minn = -1;
        printf("%d\n", minn);
    }
    return 0;
}


相關文章