HDU 5339 Untitled (狀態壓縮列舉)

_TCgogogo_發表於2015-08-02


Untitled

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 570    Accepted Submission(s): 291

Problem Description

There is an integer a and n integers b1,,bn. After selecting some numbers from b1,,bn in any order, say c1,,cr, we want to make sure that a mod c1 mod c2 mod mod cr=0 (i.e., a will become the remainder divided by ci each time, and at the end, we want a to become 0). Please determine the minimum value of r. If the goal cannot be achieved, print 1 instead.
 
Input
The first line contains one integer T5, which represents the number of testcases.
For each testcase, there are two lines:
1. The first line contains two integers n and a (1n20,1a106).
2. The second line contains n integers b1,,bn (1in,1bi106).
 
Output
Print T answers in T lines.
 
Sample Input
2 2 9 2 7 2 9 6 7
 
Sample Output
2 -1
 
Source
BestCoder Round #49 ($)

題目連結:http://acm.hdu.edu.cn/showproblem.php?pid=5339

題目大意:重排列bi,問a對重排列的數不斷取模最快能為0的取模次數

題目分析:其實是水題,首先對數字小的取完餘後再對數字大的取餘等於沒取,所以先對大數字取餘,從大到小排序,因為n很小,DFS隨意搜,也可以用狀態壓縮做,把每個數字選或不選的狀態二進位制壓縮

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MAX = 1 << 22;
int const INF = 0x3fffffff;
int b[25], sta[MAX];

int lowbit(int x)
{
    return x & (-x);
}

bool cmp(int a, int b)
{
    return a > b;
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T --)
    {
        memset(sta, 0, sizeof(sta));
        int n, a;
        scanf("%d %d", &n, &a);
        for(int i = 1; i <= n; i++)
            scanf("%d", &b[i]);
        sort(b + 1, b + n + 1, cmp);
        for(int i = 1; i <= n; i++)
            sta[1 << (i - 1)] = b[i];
        int cnt, ans = INF;
        for(int i = 1; i < (1 << n); i++)
        {
            int tmp = a;
            cnt = 0;
            for(int j = i; j > 0; j -= lowbit(j))
            {
                tmp %= sta[lowbit(j)];
                cnt ++;
            }
            if(tmp == 0)
                ans = min(ans, cnt);
        }
        if(ans == INF)
            printf("-1\n");
        else
            printf("%d\n", ans);
    }
}


 

相關文章