zcmu1074: 求1+1/2+1/3+...+1/n

三井壽迷弟發表於2020-11-24

1074: 求1+1/2+1/3+…+1/n

Description
輸入一個正整數 repeat (0<repeat<10),做repeat 次下列運算:
讀入 1 個正整數 n(n<=50),計算並輸出1+1/2+1/3+…+1/n (保留3 位小數)。

Input
見sample

Output
見sample

Sample Input
2
2
10
Sample Output
1.500
2.929

程式碼

#include<stdio.h>
int main()
{
    int i,a,b,n,x,repeat;
    double sum,item;
    scanf("%d",&repeat);
    for(i=1;i<=repeat;i++)
    {
        a=1.0;
        b=1.0;
        sum=0.0;
        scanf("%d",&n);
        for(x=1;x<=n;x++)
         {
            item=a*1.0/b;
            sum=sum+item;
            b=b+1;
         }
            printf("%.3lf\n",sum);
    }
    return 0;
}

相關文章