1088 Rational Arithmetic (20分)
For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.
Input Specification:
Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.
Output Specification:
For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.
Sample Input 1:
2/3 -4/2
Sample Output 1:
2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)
Sample Input 2:
5/3 0/6
Sample Output 2:
1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf
字串處理,yyds,難得要死
#include<iostream>
#include<cstdio>
using namespace std;
typedef long long ll;
struct Fraction{
ll up, down;
}a, b;
ll gcd(ll a, ll b){
return b==0 ? a:gcd(b,a%b);
}
Fraction reduction(Fraction result){//化簡
if(result.down < 0){//分母為負數,令分子和分母都變為相反數
result.up = -result.up;
result.down = -result.down;
}
if(result.up == 0){//如果分子為0
result.down = 1;//令分母為1
}
else{//如果分子不為0,進行約分
int d= gcd(abs(result.up), abs(result.down));//分子分母的最大公約數
result.up /= d;//約去最大公約數
result.down /= d;
}
return result;
}
Fraction add(Fraction f1, Fraction f2){//加法
Fraction result;
result.up = f1.up * f2.down + f1.down * f2.up;//分數和的分子
result.down = f1.down * f2.down;
return reduction(result);
}
Fraction minu(Fraction f1, Fraction f2){//減法
Fraction result;
result.up = f1.up * f2.down - f2.up * f1.down;//分數差的分子
result.down = f1.down * f2.down;
return reduction(result);
}
Fraction multi(Fraction f1, Fraction f2){//乘法
Fraction result;
result.up = f1.up * f2.up;
result.down = f1.down * f2.down;
return reduction(result);
}
Fraction divide(Fraction f1, Fraction f2){//除法
Fraction result;
result.up = f1.up *f2.down;
result.down = f1.down * f2.up;
return reduction(result);
}
void showResult(Fraction r){
r = reduction(r);
if(r.up < 0) printf("(");
if(r.down == 1) printf("%lld",r.up);//整數
else if(abs(r.up) > r.down){
printf("%lld %lld/%lld",r.up/r.down, abs(r.up) % r.down, r.down);
}
else{
printf("%lld/%lld", r.up,r.down);
}
if(r.up < 0) printf(")");
}
int main(){
scanf("%lld/%lld %lld/%lld", &a.up, &a.down, &b.up, &b.down);
//加法
showResult(a);
printf(" + ");
showResult(b);
printf(" = ");
showResult(add(a,b));
printf("\n");
//減法
showResult(a);
printf(" - ");
showResult(b);
printf(" = ");
showResult(minu(a, b));
printf("\n");
//乘法
showResult(a);
printf(" * ");
showResult(b);
printf(" = ");
showResult(multi(a, b));
printf("\n");
//除法
showResult(a);
printf(" / ");
showResult(b);
printf(" = ");
if(b.up == 0) printf("Inf");
else showResult(divide(a, b));
return 0;
}
相關文章
- CC Arithmetic Progressions (FFT + 分塊處理)FFT
- ACM Arithmetic ExpressionACMExpress
- 一個分數類的實現——Rational類
- Linux_Arithmetic_SequenceLinux
- [Bash] Backticks, xargs and Arithmetic
- 2010 IBM RationalIBM
- (hnust 1208)Problem C: Primary Arithmetic(水題)
- hdu 1088 Write a simple HTML BrowserHTML
- LeetCode 413 Arithmetic SlicesLeetCode
- P1088 [NOIP2004 普及組] 火星人
- Leetcode: Arithmetic Slices II - SubsequenceLeetCode
- 呼叫 Rational CM API 實現 Rational ClearQuest 的相關操作API
- Rational Rose 2003 下載及破解方法ROS
- [ARC145D] Non Arithmetic Progression Set
- Rational Software Architect 和 Rational Application Developer 之間的 shell 共享APPDeveloper
- 協同使用 IBM Rational Requirements Composer 和 IBM Rational RequisiteProIBMUIREM
- 遞推 - 動態規劃 - 百練 1088 滑雪動態規劃
- Acwing Arithmetic Learning:資料結構(2)資料結構
- Rational Rose 7.0安裝教程ROS
- zt IBM Rational 軟體IBM
- D版 Rational Rose 2001 完全安裝手冊 (轉)ROS
- 巧用 Rational Functional Tester 的 IWindow 介面Function
- Rational Rose技術交流(一) (轉)ROS
- Rational Rose技術交流(二) (轉)ROS
- Rational ClearCase Windows安裝手冊Windows
- ClearCase 、ClearQuest 、Rational Protfolio Manager下載地址
- Rational ClearQuest 安裝、配置、使用手冊
- IBM Rational Asset Manager 基礎安全IBM
- WebSphere CloudBurst 與 Rational Automation Framework for WebSphereWebCloudFramework
- 整合WebSphere BusinessModeler和Rational Asset ManagerWebSSM
- Win10 安裝Rational Rose 7.0 教程Win10ROS
- Web 安全與 Rational AppScan 入門WebAPP
- Rational Quality Manager V1.0.1 的新特性
- 使用Rational PureCoverage測試程式碼覆蓋率
- IBM Rational ClearCase 和ClearCase MultiSite V7.1IBM
- 配置 Rational Functional Tester 在 Linux 上執行FunctionLinux
- 用Rational工具管理中小專案需求與測試
- Rational Performance Tester 資料關聯規則詳解ORM